SmartThings Community

Amazon Echo Turning On Lights at 25%

amazon'alexa'echo
(Realsol) #14

@NeverOne99, I have been testing my Bedroom GE Links this morning. If I toggled the bulb off from within the Android app, I see in the log that the ‘Set Level 0’ is being sent to the bulb. When I toggle it back on, it is dim, not 100%. This might not be a Echo issue.

0 Likes

(Scott G) #15

What device type are you both using? Stock? Can you check the device page in the IDE to verify?

I checked the stock device and it should be sending a simple off() command, so maybe it’s an Android bug.

0 Likes

(Realsol) #16

@Sticks18, I am using the stock ‘GE Link Bulb’ device type with Android App, although like @NeverOne99 stated, this happens when triggered also by Echo (virtual switch), or in my testing, just clicking on it within the Android App.

0 Likes

(Jeremy Carrigan) #17

I heard back from ST support and they said the proper way to operate the bulbs is to say “Alexa turn on (light name) to n%.” I have tested this and it does work.

0 Likes

(Jason "The Enabler" as deemed so by @Smart) #18

I’ve never had to do that… It usually turns them on at whatever the last setting was.

0 Likes

(James) #19

Wow is this confusing. It’s as though there is a default 25% level set for dimmer devices that gets sent for Alexa dimmer “on” requests unless you (magically?) mess with the dimmer level enough to get rid of it.

I’m using the Echo with my own lighting integration and can literally see my Echo “on” requests change from “setLevel” requests to “on” requests after fiddling with the loads level a bit. No idea why…

0 Likes

(Travis) #20

I’m controlling 2 GE link bulbs with the echo snd haven’t had any issues. I usually run mine at a lower level anyway so if they do come on at a lower level, it doesn’t bother me.

0 Likes

(Jason "The Enabler" as deemed so by @Smart) #21

I’ve had up to 28 GE link bulbs connected to both a wink hub and a ST hub and I’ve never had this problem with echo.

How do you have the bulbs set up in st? Are you using any smart apps with them?

0 Likes

(James) #22

I have a custom SmartApp and Device Handlers to interface to my home lighting system (Vantage Q-Link). Inside my Device Handler for my dimmable lights, I can see Echo originated requests perform setLevel(25) requests when asked to turn ABC “on”.

If I fiddle around with the level for ABC using the SmartThings app (and maybe toss in a few refreshes), then all of a sudden the Echo “on” requests come in as actual on() commands for ABC. Some time later it will just revert back to the setLevel(25) calls for “on” instead. Asking the echo to “Set ABC to X %” always works properly for the dimmer devices, but with 150 lights/fans/etc (some of which are not dimmable), it’s a little more than I can ask the family to remember. :slight_smile:

I’d love to see the Echo code that is making the device calls. For now I’m literally ignoring setLevel(25) calls on my dimmable devices and changing them to “on” calls. Total hack.

1 Like

(Phish420) #23

I am having the same issue. Setting brightness to 100% works till I turn off once or twice then goes back to default dim when I turn it on. Can’t get anther with tech support.

0 Likes

(Jason "The Enabler" as deemed so by @Smart) #24

Using rule machine I created a rule that uses a virtual switch.

When I say to Alexa, turn on kitchen lights. She turns on the virtual switch, which triggers the rule, which turns on my five kitchen lights and sets the level to 99%.

It has worked perfectly since I set it up.

0 Likes

(Doug Eubanks) #25

When I ask Alexa to turn the lights on, instead of sending an “on” command, she’s sending brightness 25%. I’ve found it in the logs of the webserver that handles the requests.

"GET /Milight/milight1.php?command=brightness&group=1&brightness=25

I haven’t found a way to change the brightness on start up yet.

Doug

0 Likes

(Glenn) #26

This happens to my hue light strips in my kitchen. Quite annoying. I’ll try to modify the way I ask Alexa to turn on the lights I guess.

0 Likes

#27

Jason, I like the method that you are using! However, in my first floor area, I’ve got over 40 lights/switches for my kitchen, living room, and entry area. It’d be nice to be able to create a virtual switch and then have Alexa just turn that “switch” on/ off and at a certain level (i.e. 99%), rather than using the groups that are defaulted. I’m thinking this would be awesome for a movies scenario (“Alexa, turn on movies”). Can you help me with setting this up, or at least getting me to the rules machine? Do I do this within IDE? Thanks!

0 Likes

(Dale C) #28

@jgm1937 [quote=“bamarayne, post:24, topic:27710”]
When I say to Alexa, turn on kitchen lights. She turns on the virtual switch, which triggers the rule, which turns on my five kitchen lights and sets the level to 99%.
[/quote] I was curious why you didn’t use the Amazon Alexa app built in group control for your kitchen lights? I have 4 sets of kitchen switches that I just grouped into a single KITCHEN group that I voice control for on,off, or dim. Does the Rule Machine and virtual switch do something more that I should be considering?

[quote=“jgm1937, post:27, topic:27710”]
However, in my first floor area, I’ve got over 40 lights/switches for my kitchen, living room, and entry area. It’d be nice to be able to create a virtual switch and then have Alexa just turn that “switch” on/ off and at a certain level (i.e. 99%), rather than using the groups that are defaulted. I’m thinking this would be awesome for a movies scenario (“Alexa, turn on movies”).
[/quote] I do something like that now but not through Rule Machine. Are you using Alexa Helper by @MichaelS? This is a must have with your Amazon Echo. I have a virtual switch called Movie Lighting VSS that Alexa Helper monitors that when switched ON initiates a simple custom SmartThings routine called Movie Lighting. This routine turns off all the lights I want off, and for the lights that stay on they are dimmed to 20%. All I say is “Alexa, turn on Movie Lighting”

1 Like

(Jason "The Enabler" as deemed so by @Smart) #29

This is because of the firmware bug of the GE Link Bulbs (which I’m using) which causes them to turn on at 25% unless I specify a level. I didn’t want to say, Alexa, Set kitchen lights to 100% every time. I wanted to say, Alexa, turn on the kitchen.
The virtual switch actually triggers a rule that turns on and sets the bulbs to 100%. I do not turn on all of the bulbs unless I want them all at full brightness.
If I want a dimmer light, I just have her turn on the light in that section of the kitchen.

1 Like

(Dale C) #30

Thanks for the help, that is interesting, I didn’t know they were buggy. I have a couple of those GE Links but not in my kitchen.

1 Like

(Mike Reed) #31

I don’t know if this helps much but I had that issue using the GE Link bulb v2 device handler. If I switched to using the built in one it worked fine. I have to use v2 though since it is the only one that works with a bulb connected to the Lutron remote. I poked at the code between the two and i “think” its working by pulling the parse subroutine from the previous device handler and swapping with the parse in v2.

So far two days, the brightness is at 100 when turning on and the lutron remote hasn’t lost its connection yet. I am just getting started myself and only know some C++ and VB so I’m all thumbs on it currently.

0 Likes

(Mike Reed) #32

Nevermind. It started the 25% thing but only on the bulb connected to the lutron remote. :\

0 Likes

(Kevin) #33

I can now say it does this same ‘bug’ to Cree Connected bulbs. I did the set slider to 99 and hit refresh a few times, and so far thats helped. I know that the cree’s default to 100% on power pull. So I know its not the firmware doing it on the cree’s. My second or third try with all the stock integration, no alexa helper, its mostly worked. Ill see what the future holds tho.

0 Likes