Amazon echo and monoprice dual relay


(Umpmanjoe) #1

Continuing the discussion from Monoprice Dual Relay On/Off Device type 11990:

does anyone know who to get amazon echo to recognize the monoprice dual relay? I have it installed and my smartthings recognizes it, however when I run discovery, amazon echo doesnt find them


(Ben Lebson) #2

You have to go into the Amazon Echo smartApp and authorize the Echo to see that device.


(Umpmanjoe) #3

i’m in the smart app and scrolled down to bottom and hit discover devices, but it doesn’t find them. It is already linked with smart things and its finding my other smartthings zwave devices like the lmf20 and intermatic timer


(Ben Lebson) #4

You need to go into your already installed smartapp, the one that has a list of all the devices currently added to the Echo. In there you’ll need to add the new relay (assuming it has a ‘switch’ capability).


(Umpmanjoe) #5

I’m very sorry, but I’m new to all this code stuff. Am i supposed to have a smartapp in smartthings for amazon echo? I never installed anything like that. Echo automatically found all my other devices located on smartthings when I linked it in the amazon echo app


(Ben Lebson) #6

No worries, we all start somewhere :slight_smile:

When you link the echo to your SmartThings account it creates a SmartApp within the SmartThings app automatically. Go into the SmartThings app, click on the menu in the upper right, go to SmartApps, then to “Amazon Echo”. Within that SmartApp you will see a list of all the devices approved for use with the Echo. If you click on the list it will allow you to add/remove any devices on the list.


(Umpmanjoe) #7

Thank you so much. I got it. One other question if you don’t mind. I bought 4 of these monoprice dual relay. I have it set up as this device “Enerwave Dual Load ZWN-RSM2” using this smartapp "Enerwave ZWN-RSM2 Adapter’ so that smartthings will show each relay as 2 devices each with their own tile.

If I want to hook up more than on monoprice dual relay on my hub, do I need to install multiple instances of the smartapp awn-rsm2 adapter? I had 2 of the relays installed but once I did the smartapp for the second one, neither worked. As soon as I removed one of the relays, the other worked again


(Ben Lebson) #8

I’m not totally familiar with it, you’d probably be best asking that question in the SmartApp post on the community.


(Ray) #9

Yes you have to install another instance of the smartapps adapted per relay. I have a few of this relay and to make life easy. You name the dual relay device and the smartapps adapter with the same name. My relay would be something like emerwave kitchen light dual Relay. My adapter would be emerwave kitchen light dual Relay adapter. My 2 virtual switches for the relay would be something like kitchen light sink, kitchen light cabinet. Hope that help.