Amazon Alexa Sent refresh command to

Last night all of the sudden Alexa started doing this many times in a few minutes to all my Zwave devices. It has not done it before. What gives? Last night it appeared on a couple of devices. This morning all of them.

Thanks

1 Like

I saw that last night my Amazon Alexa app for iOS was updates. In the release notes notes it said: “The updated Alexa App Smart Smart Home section lets users rename, view the state of, and control smart lights, locks and thermostats.”

Is this to make sure the state is updated periodically?

I wonder if this is for the new Echo Plus, which DOES allow for direct control of Zigbee devices. I am not near my devices right now, but I don’t believe the native integration allows you to poll the status of a device…does it?

G[quote=“hotsparks, post:4, topic:102921”]
devices
[/quote]

This is only happening on my Zwave devices. Which Alexa plus does not support.

Don’t get me started on the software update.

This is my review of the new Alexa update.

Lost control of removing smarhome devices.

After this mornings upgrade I see no way to remove a smart home device. And after doing a search it comes up as a device is working fine when in fact it is not connected. And it has created duplicates of many of my devices. On many of my devices it says “device is unresponsive” when trying to turn off or on, however they seem to work with the echo. This was not ready for release!! I did remove a switch and readd it and it’s still happening. I unplugged all my Alexa devices at once replugged and still happening. It just started last night.

Only way I’ve found to resolve this is to remove the device from smartthings completely and re-add it.
Then do a discovery in the Alexa app.

Having the same problem here with all Arlo and Sengled connected bulbs:

I almost hope this is not the case. There is great benefit sometimes in not needing to know a device’s state, yet sending it a command anyway. If I want something powered off, what do I care whether it reports as ‘on’ or not?? If it has discrete on and off commands, it can be very useful indeed.

Imagine an Alexa “turn off living room” command that fails, because one of the devices in that room is already reporting as ‘off’. In fact that is exactly the scenario that occurs many times in ST, and a large reason why I make my groups in Alexa rather than as simu/virtual switches in ST.

Don’t know but I can tell you those refreshes were showing up in my logs way before this Alexa app update. There are other threads in here talking about it.

I had a light set off to go on and off with the sun. It has worked flawlessly except this morning it did not shut off. And I noticed that it was told to go off the same time Alexa sent a refresh command to the switch. The switch did not turn off. I believe because of this Alexa refresh command.

All the same issues here, as above. My automated lights for outside missed started missing the defined schedules to turn off, right after this Alexa update. Also, I’m very frustrated that I cannot seem to “forget”a device in the Amazon app anymore. You can only disable it. This is ridiculous since I had removed a couple items from my inventory, now they are still appearing in Alexa app.

Hope an update is sent soon to fix this. If anyone has automated locks or garage doors I’d be worried that the refresh could inadvertently breach your security.

Amazon started about 5 of my 30 devices? All devices are on Amazon. My SmartThings only has

Amazon Alexa App.

For Amazon, I only have SmartThings enabled in the SmartHome (no other), so it is (by design) a minimal installation.

Considering the platform bog-downs that frequently occur, I am very concerned about this every 10 minute refresh for devices. How can I prevent it (programmatically) in the apps I write? In general device handlers?

Further examination: Devices they are monitoring media words in the device name. Soundbar, Camera.

Just wanted to chime in on this.

Spoke with amazon support - the ability to delete devices in the alexa app is not coming back per the rep.

You can however login to the alexa web interface and the delete option is still present and works properly.

This is something I stumbled across when trying to delete devices, too. Thanks for the confirmation :sunglasses:

What’s the url for the Alexa web interface? I only find Alexa.amazon.com which forces the app download.

Thx

Never mind. I logged in to the alexa.amazon.com with Windows PC and was able to load the web interface. The iOS devices forces the app download.

Thanks this is great. I’m attempting to FORGET all the devices and rediscover to see if that solves the refresh issue

I have two spare cents, so here I go:

  1. The overhead for these extra refresh commands (every 10 minutes) is in my view excessive. The Alexa App should subscribe to events from the devices. The device handlers should control polling / refresh cycles based on the use case. Events it subscribes to should be based on the attributes of the Amazon selected capabilities.

  2. DTHs should be reviewed to assure they are polling (refreshing) at rates commensurate with the use-case.

  3. Even if no changes are made, AMAZON owes the user community DOCUMENTATION on what causes the refresh command to trigger!!! I know for a fact that I have eight devices using the same DTH. Some are “refreshed” by Amazon, some are not (those that are refreshed have “soundbar” in the name (i.e., left soundbar power). Others are not. PLEASE PROVIDE DOCUMENTATION or guidance.

1 Like

I am also having the “Device is unresponsive” issue and have tried a number of things to troubleshoot in both SmartThings and Alexa. I’ve reached out to support for both and Alexa has responded acknowledging the issue being widespread without any known work arounds.

Upon attempting to re-add the device everywhere, I was left without the ability to re-add the device to Alexa.

I spent a couple hours with Alexa Level 2 support yesterday, with little to no path to fix. Basically, I was told that the Alexa support line only supports the hardware, not the actual software, although acknowledges the issue. So, they have logged the incident and “said” they would escalate to developers. However, there is no further support ticket to track. Lame!!

I did identify exactly when this started to occur, based on the smartthings dev web interface by going to

  1. Log on to https://graph-na04-useast2.api.smartthings.com (This will log you in to your account.)
  2. Click My Locations and Select your location
  3. Click Events

You will see the APP_COMMAND refreshes. I scrolled through about 15 pages and located the first refresh command on 10/24/2017 at 10:35 PM EST. Also, you can click on the LIVE LOG and wait to watch the refresh occur again

Really, hope they push a fix for this soon.

I got a response from the Smartthings support team here, Looks like there was an issue in the code. It was sending to all devices, not a specific subset of devices:

2 Likes

As of this morning, I am no longer seeing the REFRESH commands through the recent events screen. WooHoo!!

I did confirm that I am still seeing the “detectHearbeat” coming in regularly from Alexa SmartApp Job History which is normal operations. So, it looks like all is well again.

This issue is still occuring for me and since 4 pm est today(11/01) the refresh is every minute instead of the 10 min interval.