Alexa says devices not responding after internet outage

Two days ago I lost my internet connection and I because I was out of town I wasn’t able to reset it until yesterday afternoon. Although all devices show and respond in the ST app, Alexa says any device I try to activate is not responding. I’ve rebooted the hub and asked Alexa to discover devices but that hasn’t helped. Any thoughts as to what might be wrong?


1 Like

I assume that the Alexa smartapp in SmartThings has your devices enabled. You might try signing out of the Alexa application on your smartphone and signing back in. You could also try disabling and reenabling the SmartThings Alexa skill.

Thanks for your reply but neither suggestion worked. All was well until the internet problem 2 days ago.

1 Like

I think I know why this is happening but I don’t know how it happened or how to fix it. When I look at all devices in the Alexa app I see 2 - 4 entries for almost all of my devices (see attached). When I select the first entry for a device, it gives me the correct status. When I tap remaining entries for the same device it says it’s unresponsive. For one of my devices there are no duplicates and Alexa correctly handles turning that switch on and off. I guess I need to figure out how to clear the duplicates or get rid of all devices in the Alexa app and re-discover them.

You should be able to use to remove all the devices faster than using the Alexa app. (There’s a forget all button.) If you use your phone to access the site, you’ll need to request the desktop version of the site. Otherwise it will prompt you to download the app.

That seems to have fixed it. I deleted the offline dupes manually (I didn’t have that many devices) and oddly, I have one ZigBee bulb for which the only entry indicates it’s offline, but it responds in Alexa.

Thank you for you help!

1 Like

For others with this problem . . .

I didn’t have dupes but all devices were not responding and they all showed offline in I resolved the issue by forgetting and re-adding the devices. (I had to re-add my groups manually.)