SmartThings Community

Alexa can open Schlage smart locks now


(jkp) #1




(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

We’re always ahead of our time.


(Glen King) #3

Yep. Been doing this since Alexa arrived in my home. Without a PIN.

Gotta say, I’m surprised they did not hook itnto the voice recognition feature instead of a PIN.


(Jimmy) #4

With SmartThings it’s not just Schlage locks. Can do it for my August Pro, too. They also added the ability to set a device as a light or switch/plug. That way “turn off the lights” doesn’t turn off fans, appliances, etc. Two very nice additions!


(Lee Florack) #5

I have a Kwikset lock and Alexa works with it too. Just need to set it up in the app with a voice PIN code.


(MarkTr) #6

Mine is “unavailable” in Alexa app but still looks fine in ST (Classic). Need to check into it more tonight…


(jkp) #7

Is your Alexa app up-to-date on your mobile device?


(MarkTr) #8

Good point - there was an update waiting, but that hasn’t changed anything. It says “There is a problem with [lock name]. Please check on your lock.” and a banner at the top indicating the device is unresponsive. But under “Edit” I have the option to turn on the new unlock features.


(Daniel) #9

I’m trying to do the same thing, but it looks like the Alexa app (iOS) has changed, and I can’t seem to make this work. There’s no Smart Home item in the menu, though tapping Devices gets you to what’s probably the same list. When I tap on my lock, however, there’s no Edit to get to the Unlock by Voice.

Any tips on how to get to the Unlock by Voice switch?

For the record, the Schlage Connect lock otherwise appears to be connected properly. I can say “Alexa, lock the front door” and it does. I just can’t unlock it.


(Lee Florack) #10

Click on the icon in the lower right. You’ll see your devices by type across the top. Scroll to the right until you see ‘Locks’ and click on it. Then click on the lock you want to be able to unlock via voice. On that screen, click on the three dots in the upper right. The ability to enable Unlock by Voice is on that page. You’ll be asked for a PIN# you want/have to use.


(Daniel) #11

Hi Lee,

The image I attached is that screen. I got there with the steps you specified. There’s no Unlock by Voice.

Just to confirm, I loaded up the Alexa app on another iOS device and logged into the same account, with the same result.

What am I missing? Maybe a permission set somewhere else in Alexa/the app/ST/Schlage?

Much appreciated,

Daniel


(Lee Florack) #12

Just to make sure…
I’m using the Alexa App on IOS
Client Version: 1.24.204528.0
App Version: 2.2.243227.0

What versions are you using?

If you’re at the same version levels, check in the ST/Automations app to endure you’ve selected your lock in the Device Authorization section.

If that’s done, the only other thing I can suggest is to try to exclude your lock and re-add it. Maybe it’s not fully/properly connected.


(Daniel) #13

Alexa
App running on an iOS 12.1 phone.
Client version: 1.23.204553
App version: 2.2.243227.0

Which ST app - classic or new one? I don’t see anything in either about “Device Authorization”, but I do have the Smart Locks app installed, see Smart Locks on my dashboard, and can address the Schlage by locking/unlocking or adding a new code.

I tried moving the declared location from Canada back to the US. That wasn’t it.

If all else fails I’ll exclude and re-add it.


(Lee Florack) #14

I’m using the ST Classic app. To find the Device Authorization page, select’Automation’ on the bottom of the ST Classic App., then choose the SmartApps page. Once there, choose the “Amazon Alexa” smartapp. You just need to make sure that the lock is selected/authorized - or that the “Allow Alexa to access all devices, Scenes and Routines” is selected. It probably already is, but just checking.

Good luck!