After factory resetting my Samsung Galaxy Book Flex 2a I can't reactivate Find My Device

After factory resetting my Samsung Galaxy Book Flex 2a I can’t reactivate Find My Device on the new Windows installation. When trying to re-setup Find My Device on the Galaxy Book, I receive this image. I have talked to several support agents, and they told me to post about the issue here. There seems to be no way to reregister this device to my account again and I’m not sure what account it is talking about. I’m the only one who has ever owned this computer I purchased brand new from Best Buy.

Find My Mobile is Samsung’s service for tracking and locating mobile devices and has been around for years but has always been web based. More recently they introduced SmartThings Find which works in the SmartThings app but still works with the Find My Mobile back end.

So to me that error suggests that before you reset your Galaxy Book it was being used with a different Samsung account. I don’t know how that gets set up on a Galaxy Book as I’ve never seen one, but it will have been used to set up Find My Mobile.

Since the reset, it would appear that you are using a different Samsung account to access SmartThings Find and that is causing problems as the device is still on that old account.

That is what it is saying to me anyway. Whether that is actually the case is another matter.

Thank you Graham! Yes that is what I thought too however I checked, and I used the same Samsung Account so I’m not sure why it thinks it is registered to another Samsung Account?

Out of curiosity, have you tried logging in to https://findmymobile.samsung.com/ just to see what that says?

Yes, I just checked it only shows my phone and watch no computer.

Contact support and tell them that you cannot set it up and they should remove where it is currently registered.

Nobody in this community can help more that this.

We can only tag some SmartThings employees or partners to help, like @erickv or @garrett.kranz, maybe @nayelyz.

But this shouldn’t really be a SmartThings issue, but a Samsung issue…

Thank you for reaching out, @GSzabados.

Yes, @abacklund, if you have issues (non-developer related) regarding the SmartThings app or the desktop version, you should contact customer support (enter this page and click on “Support”, at the bottom, you’ll find the different options to contact them)
If you haven’t done that yet, maybe @SamsungZell could give us a hand with this issue.

Hey there! @abacklund I’m sorry to hear that you are having issues with the registration of your Galaxy Book Flex to have the capability to display location using Find my mobile but having issues with the associated Samsung Account.

I was not sure if you contacted the services directly, so I first wanted to provide you with the US contact information for each separate service to reach out to so that we may further assist you with your concerns. As it appears to be a sync issue between the registered device on the Samsung Account and Find my Mobile.

Samsung Accounts - 1-855-795-0509
Find My Mobile - 1-866-647-9190
Note: Contact numbers for reaching specific Apps and Services can be located here: https://help.content.samsung.com/csweb/tutorial/searchContactNumbers.do

As mentioned, Find my mobile is used in Smart Things Find as displayed in the screenshot below, which locates your mobile device, and paired devices that have been enabled for Find My Mobile

I recommend following up with support, but I wanted to confirm what troubleshooting steps that you have already attempted by having you elaborate on a couple of steps, apologizes if you have already attempted these and the symptom persisted.

  1. As you verified that it does not appear in the Find My Mobile web page, Have you already tried logging in and out of your Samsung Account at: www.account.samsung.com and checking the Devices tabs to display the below menu:

We would first need to work with you to resolve the registration issue before moving forward, keep me posted on the results once you have spoken with that specific service(s). You will be in good hands there!

I hope this message finds you well!

^SamsungZell