Aeotec Nano Switches going offline since Edge

Hi there. I have 8 Aeotec Dual Nano zwave+ switches (0086-0103-0084) that had been working fine for 2 years. A few weeks ago, half of them started to become slow, unresponsive and then simply went offline. They were on stock DHs and are now on stock Edge drivers.

No changes at all were made in the zwave network (or any other device), and the only way to bring them back only is to phisically bring them less than 2 meters away from the hub, exclude, and include them again. But once they are back in their original position (as in the last 2 years) they go offline again. Here’s what I tried:

-Hundreds of network repairs, hub reboots, switches power cycling, with the same error (no route).
-Looking for differences with the other switches that are working just fine, that some are closer and some further away, but I found no differences. There are both direct-to-hub and meshed in both groups.
-Adding (new) Aeotec extenders up to 2 meters from the switches, no change at all.
-Trying Mariano’s drivers (similar results, maybe a tad bit better)
-Thinking that maybe some radios got fried, I added a brand new switch that I have as spare, with identical results.
-Thinking that maybe my hub radios were the problem, added a new hub (v2) that I had, with identical results.

My only conclusion is that something else has changed in the way the zwave network works now, like if the hub had less power and range, and extenders had no effect at all. Everything is zwave plus from a couple of years, so it’s not old gear either. Anyone else is experiencing the same issues? Thanks,


Facing same issue. The switches are either unresponsive or goes offline altogether. Did you find solution on this? @JPBuiatti ?

Not really. I ended up adding more Aeotec extenders to reduce the problem, but it happens again from time to time.

I’m totally new to SmartThings as I just got my hub. After installing my Nano Dual switches [ZW132-B], I found that Aeotec have specialised drivers for these. The specialised drivers install the ZW132 as a single device whereas the generic “Z-Wave Switch” driver installed them as two devices. I know nothing about Edge drivers but just possibly it’s worth a try?

Good luck.

Hi Chris. I have tried both them. The Aeotec drivers are a tad bit more stable than the stock ones, but they suffer the same “zwave coverage” issue. I even changed the hub (and the entire network) to the Aeotec (a v3 essentially, from my prior Samsung v2) but made no difference. I suspect this has something to do with Smartthings and their new software stack and how they handle zwave events. Hopefully it will eventually be fixed in the near term. Thanks!

Hi JP. Your response gives me that sinking feeling… I’ve already noticed how erratic the response times are when I switch things ON/OFF from my Android phone. Sometimes fast, sometimes a few seconds.

I avoided products like Home Assistant on the grounds that it was too much a hackers paradise. I assumed that SmartThings was a stable environment. I think I got that wrong. Aeotec don’t even have Edge drivers for the Nano (single relay) switches. Today I’ll be testing whether these will work properly with the generic driver. It is just day 3 for me with [the NOT so]SmartThings but I suspect I’ll be looking for a new hub/environment. All the best with your system.