Aeotec Multipurpose sensor to detect vibration in stairs

I have two sensors in my staircase to sense vibration when some one walks up or down. I’ve put sensors under the steps in the top and bottom of the staircase. Automation is set when vibration is detected staircase light goes on. Motion sensors are out of the question due to cats in our household. They’d activate light every time they go by. And they love to run those stairs up and down.

But these sensors are not sensitive enough to sense the vibration everytime from that moment when someone starts going up or down. Sometimes vibration is not detected at all and sometimes after the few first steps. My staircase is not old and made from hardwood. They do creak little bit so there is a movement in the structure itself but not enough to activate the sensors.

I need tips and tricks to set these sensor so they could be as reliable as possible.
I know there’s option to use pressure sensors because we have padding on each step and sensor could be put under the padding but I’m not ready to give up on this, not yet. Any ideas?

The Fibaro sensors are more sensitive with adjustable settings (in this case, use the tamper sensor parameters). Otherwise you might be able to set the Aeotec sensor itself (NOT where people walk) on a material that would magnify the vibrations and fool the sensor. Sometimes just a small bit of metal is enough to get this effect.

Can you put a sensor at human shoulder height and limit its detection field and catch motion there? That’s a common method for addressing cat/sensor issues. :smile_cat:

A lot of people put a short tube over the lens to limit the field. Or use a bit of masking tape on the lower half of the lens.

1 Like

I’ve actually thought about that and I seem to have enough material to try this out. I have thin steel strapping that could be used.

1 Like

I could but our upstairs/living room is open space so it will detect all the motion in our upstairs. I’ve tried it already. :smile:

1 Like

Did you try adding a tube to make it a spot detector instead of a zone detector?

This one is ugly, but it demonstrates the concept.

image

Here are some nicer looking ones


@Sakari
I tried using the Zooz ZSE43 for something kind of similar detecting footsteps and I did not work in my case, so just FYI, if you came across these in your lookings. They just werent sensitive enough either for me.

@JDRoberts those photos are hilarious, but get the job done, I guess.

1 Like

No, I have used tape to narrow the detection zone smaller. I’m absolutely going to try these tube hacks.

I’ve only used thse Aeotec sensors. Those are the ones easily available for me.

1 Like

Hi @Sakari,

With these aeotec, old samjin, multipurpose sensors you can attempt one thing.

The edge drive stock zigbee contact, in the configuration has a threshold value of movement, vibration.

In my driver I did not implement it to be configurable, but I could do it in August, when I have access to the cli.

If you dare with the CLI, you can modify the value 0x14 down to 0x1 in the file: SmartThingsEdgeDrivers/drivers/SmartThings/zigbee-contact/src/multi-sensor/samjin-multi/init.lua, line 34 and create your own driver and go testing.

Also, some kind soul could create a driver for you to test with the value 0x1

3 Likes

Thanks, I could check this out later this evening. It shouldn’t be that hard. :crossed_fingers:

2 Likes

Hi @Sakari

If you need any help to modify and create the driver tell me and I will try to help you

Since the modification affects the configuration, you will have to uninstall and reinstall the device. This driver does not perform configuration with driver change.

For the driver to have a different name you have to modify the name in the config.ymal file

This guide can help you.

1 Like

No problem. I have only two devices which this will affect. I just had a long and exhausting day, I’ll get back to this tomorrow when rested and refreshed. Thanks for all the help already.

2 Likes

It took me an hour to get hold of how to edit and publish the driver. It was quite easy actually. Your tutorial was simple and straightforward.

I changed the value from 0x14 to 0x1 but what does this value mean de facto? What does it change? Make it more sensitive?

2 Likes

Hi @Sakari
The FC02 cluster, acceleration, is a manufacturer specific cluster and there is not much information or I did not find it.

Lowering the threshold is supposed to increase the sensitivity.

There are two thresholds, the multiplier and the movement threshold, in this manufacturer only writes the multiplier.

In the smartthings manufacturer, write the two attributes, with values 0x01 and 0x0276

According to the DTH, threshold 1 = 0.063g

It’s a matter of testing and seeing if it increases the sensitivity to the level you need.

Remember that the configuration in this driver is only done in the installation from uninstalled, it is not done when changing the driver, therefore you will only see changes if you uninstall and install the sensor.

First I forgot this and wondered why it won’t work but after deleting and pairing again I can definitely say these sensors are more sensitive. Few slight knocks on the hardwood step triggers sensor. It is much better than it used to be but still not perfect when it comes to reliability. If I stand on the step and tap it with my foot few times sensor gets triggered. For some reason, when descending/ascending, first taken step wont be enough to trigger the sensor. After second step there’s vibration enough.

It may have something in the firmware to minimize false detections.

You can try to mount it on some straps or springs that make it go into oscillation with the first vibration

1 Like

That’s been in consideration. I have thin metal strap that can I could easily use in that purpose. I’ll have to see how this works. Give it a few days. Like I said, it is already better than it used to be. :+1:

2 Likes

Hi @Sakari,

I have made this version of the SmartThings Multipurpose Sensor Mc driver for you to try:

  • You can choose in preferences the profile to be an Acceleration sensor (vibration) or Multipurpose Sensor:
    • Shows in the mosaic the acceleration (Vibration). I have not been able to find an icon for vibration sensor, but you can choose between those that the app shows for a multipurpose sensor
  • You can choose in preferences the threshold for Acceleration detection, between 1 and 254. (1 = 0.063 mG)
    Acceleration threshold custom setting is also available in multipurpose sensor profile
  • I have tried with a Samjin (Aeotec) sensor and with values < 6 (0.378 mG) the vibration is always activated, Very sensible. The default value in stock driver is 20 (0x14).
    You will have to try several values to see what value works for your use.

You can make a driver change to this new version and it will work.

┌─────────────┬──────────────────────────────────────┐
│ Name        │ SmartThings Multipurpose Sensor Test │
│ Version     │ 2022-08-07T20:43:22.11475339         │
└─────────────┴──────────────────────────────────────┘

Will you tell me how it works?

2 Likes

I had already forgot this. What a nice surprise this was to see first thing in the morning. And it’s my birthday so timing couldn’t have been any better. Thanks! :smiling_face:

EDIT: Works like a charm! Is there an icon for vibration in the Smartthings?

2 Likes

Happy Birthday!! :birthday:

I have not found any vibration sensor icon.

I’ll make a few small changes to separate the smartthings and centralite model threshold accel configuration and post it to the channel

link to new version release post
https://community.smartthings.com/t/beta-zigbee-edge-driver-compatible-with-lidl-ecosmart-osram-smartthings-others/231689/2164?u=mariano_colmenarejo

1 Like