Aeotec Aeon Dry Contact Sensor

Great to hear, and glad I could help. You’re most certainly welcome @Boatman!

Here’s the section where I made the changes:

def sensorValueEvent(value) {
	if (value) {
		createEvent(name: "contact", value: "closed", descriptionText: "$device.displayName is closed")
	} else {
		createEvent(name: "contact", value: "open", descriptionText: "$device.displayName is open")
	}
}

ST’s default code had “open” where “closed” is above. I just switched the two around.

John

Good I saw that and then was not sure! Long Day. Thank You For your Help! I love the system and it is getting better thanks to you and others like you.

John

Anytime John. Don’t hesitate to ask for help.

How do you pair the ZW097 with the SmartThings hub - I only see window/door sensors in the open/close device list ?

For anyone looking for the proper answer, while you can do the aforementioned code swap, these dry contact sensors also have a configuration option for this. Unfortunately it’s not implemented in the default ST device type handler. I just got one today, so I may go ahead and publish something that works when I get around to it. For now, I’ve just changed the code to invert the value on the sensor. While this “works”, anything else that directly pinged the dry contact sensor’s value would see it as being “open” instead of being “closed”.

I actually wrote a handler for these as I use 2 of them (for smoke and carbon with kidde wired smoke detectors). I have to tweak it and I will end up publishing it shortly.

Awesome. I’ll be on the lookout!

Hello,
Interested in your DH as I just purchased two of these Aeotec Aeon dry contact sensors from Amazon. Is it available?
Thanks!
Bob

Were you able to find a Device Handler? Looking for one too

I did do a device handler to use the on board configuration to swap from NC to NO, but I’m not able to get it to work reliably. I’m guessing it has to do with secure inclusion…

This thread should have the link for the reverse contact sensor

Hello did you publish it? I am thinking to buy one

best

Simone

Someone else published it in the same thread. Works fine

I’m very confused. The link you provided is just to this thread. Where is it published?

The link and the instructions were in the same thread about 15 posts before yours (Johnconstantelo). Here’s his link and instructions. This is a very dependable sensor and device handler.

https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-zwave-reversed-contact-sensor.src/my-zwave-reversed-contact-sensor.groovy

It’s basically 3 easy steps:

Log on to the IDE with your same account you use for the phone app.

Create New Device Handler under the My Device Handlers tab (save and publish for yourself). Create it “from code” and copy/paste all the code from the github link above.

Edit the device (found in My Devices) so that it uses the device handler you just created. It’s the field called “Type*” and change it to “My Z-Wave Reversed Contact Sensor”.

Hi All,

Sorry to revive this old thread but wanted document this for anyone interested.

The custom device handler solution to change from Always-Closed to Always-Open functionality of this sensor is not very good because it makes the device execute in the cloud. I recommend keeping the standard “Z-Wave Plus Door/Window Sensor” so the device executes locally and then changing the sensor parameter 3 to value 1.

I originally thought about writing a custom handler just to change the parameter but then I found this really cool tool:

So these are the steps I followed to fix the problem and the sensor is working beautiful for me now:

1- Install the “Z-Wave Tweaker” DH (instructions on zcapr17’s thread)
2- Edit your device (sensor) and change the type (DH) to “Z-Wave Tweaker”
3- Wait for the SmartThings app to update
4- Open the back of the sensor and press/hold the button for 3 sec. This will put the device in Wake-Up state for 10 min so ST can talk to the device freely. Sensor led will blink while in this mode.
5- Go to the Device in the SmartThings App, the tile at the bottom should be Green (syced).
6- Hit the Gear at the top right corner and scroll down until you see the “Configure a Parameter” section.
7- Set the “Parameter ID” to 3
8- Set the “Parameter Value” to 1
9- Save
10- The tile at the bottom should now be Orange(sync pending) and should turn green (synced) after a couple of sec.
11- Hit the “Clean Up” tile.
12- Go back to the IDE and change the device type back to “Z-Wave Plus Door/Window Sensor”, the sensor will retain the new parameter.
13- Hit the button on the back of the sensor to go back to sleepy mode
13- Profit!

Note: After the SmartThings app updates the DH the device will still show as Closed, trigger it once and it will start working in Always-Open mode.

Thanks a lot to zcapr17 for the very useful Z-Wave Tweaker

2 Likes

@Lumute
Thank you so much for that tweak. Worked like a charm!

1 Like

Thanks @Lumute.

I hate to poke at this topic one more time but I have been using the sensor with the tweak suggested by @Lumute for a year or so now and the sensor is fine. However, I have noticed that it seems to burn through battery quickly…sometimes as short as 2 weeks.

It’s the closest thing to the hub and I don’t have this issue with any other battery powered device (at a similar or further distance) so I am wondering if it is just a defect (and hence why Aeotec basically disavows the device) or if somehow switching the mode has some negative effect on battery usage.

Anyone have any similar experience or thoughts?

Hi I use 8 of these Aeotec sensors and the battery life is relitive to how well it can contact your control (hub) But never had it as bad as you. I have had trouble with several sensors of different makes because of range, old batties the come with them and some sensors have been bad. Two houses with 97 sensors between them. A zwave wall switch will improve the signal if it is near the sensor. Check for things that make noise around it. move the Hub away some or rotate the hub (the radio is directional) Or is the change of state very often each change uses power. Fibro uses a window sensor that has a input for a external swicth.
Good Luck this stuff is always a adventure I have replaced many of my smartthings window sensors for batt use and other reasons the ones from before Samsung with AAAA batteries go 2 yrs and they all still work. The first Samsung ones are all gone the second series 50% were bad in a year and the 3rd series 10% With 25 doors and windows that has been 16 sensors replaced. Moving them around somtimes will fix the problem because they are not equal.