Accessing dry contact control on Aeotec door/window 7 sensor

Hi - I’m a relative Z-wave noob and I’m looking for help with adjusting the Aeotec door/window 7 sensor to use the dry contacts, not the magnet sensor. I am in the US, using a SmartThings Gen3. The Aeotec 7 connects to the Gen3 hub and operates well using the magnetic sensor, so I believe the device is working fine.
Aeotec has this information on their website: https://aeotec.freshdesk.com/support/solutions/articles/6000226217-aeotec-door-window-sensor-7-with-smartthings-hub . Unfortunately, when I follow their directions, I still can’t get the sensor to trigger on the dry contact connection. I’ve tried deleting and re-attaching the sensor, re-loading the custom device handlers… nothing works.

Does anyone have any info on this? Thanks for any help you can provide.

If you followed the directions exactly great! However, I think that may be the problem. Not stated in the instructions you posted is that the custom device handler will give you control of parameter 1 in the device so you can configure it to use the external contacts.

Open the classic ST app and find the device. Go to the settings page for the device (gear icon). I’m guessing Eric has a setting you can turn on there to activate the external contacts.

Hi – thank you for the reply. Unfortunately, I had enabled the dry contacts using the SmartThings classic app. I also changed the settings in the modified device handler and re-synched the sensor. All to naught. The device would not respond to the contacts, it would still only respond to the magnet.

I did find a “tweaker” device handler that allowed me to scan the parameter settings. The download indicated that Parameter 1 was still set to 0… the magnet. I could use the Tweaker to force the sensor to use the dry contacts.

The DH from Aeotech does not seem to work well.

I got the sensor to work for about a day, then the battery died. This is the second battery it went through in 3 days. Not sure why it is eating batteries, but the sensor could be bad.

It does sound like something is wrong with the sensor if it is burning up batteries like that.

Tweaker is a legitimate way to set parameters. They will stay set when you revert to a standard device handler.

1 Like

I have exactly the same problem in that the sensor is eating batteries when i use the dry contact input. Shame as it works well. Not sure if this is a design fault - it must be constantly trying to communicate with the hub. No idea how to sort it out - does anyone have it working with dry contact input? Although an external power supply could be a solution I’m not sure it really solves the problem as presumably it will be constantly drawing power? Anyone have any ideas - I’m tearing my hair out looking for a solution!
Thanks

I am having the exact same problem getting the window 7 sensor to use the dry contact input. I can’t seem to find a way to change parameter 1 from 0 to 1. My smartthings hub is about 2 years and may not be fully functional with the sensor. The controller version I have is 1.7.39-24. Is that my problem or am I missing something?

I contacted Aeotec support to try to get the dry contact sensors working. The part that wasn’t clear from the freshdesk link above is that the cover has to be off to accept setting the parameter to 1. Before I saved the setting with the cover was off, the api would say that the value was 1, but the dry contact sensor didn’t work.
However, after finally getting it to work, the battery died after 12 hours. For some reason, switching to dry contact mode just kills the battery.
I gave up after that and returned it.