Aeon Products: Secure Exchange fails

I upgraded from v1 to v2. My aeon doorbell and aeon siren both fail to include after factory resets saying security key exchange fails. The devices barely work from the app.

I am joining from within 8 feet of the hub.

Anyone have any idea about this in v2? v1 this went without a hitch.

FYI: I tried another factory reset, for a 2nd time, and this time did the include via the Minimize for the Siren. Success.

Doorbell can jump off a short pier into a deep ocean.

1 Like

Some users have had better luck using the DTHs below, but the Aeon Doorbell almost always requires that you push the action button more than once during the inclusion process.

Appreciate your efforts; they don’t work even with those handlers. Something about re-pairing with v2 network just isn’t working right. The siren worked for about 12 minutes, then ignored everything. And that silly doorbell, I hit the button more than two times. :slight_smile:

That’s too bad, these are my 2 favorites devices.

If you have the patience and can get the device within a couple of feet from the hub, it can’t hurt to reboot the hub and then repeatedly try factory resetting them and pairing them.

If you try it enough times using different lengths of time to hold the buttons in or number of times to push it in, you could end up getting lucky eventually.

Assuming your Aeon Doorbell isn’t at the bottom of the ocean, you should try the device handler below again because it no longer requires the device to be paired securely.