Minimote Headache

I recently purchased a Aeon Minimote to add to my system, and well it has been a big headache.

I can easily get the Minimote to add to the system, and I have tried using the ST handler and the Kyse’s one. Both handlers show that they are triggering button presses and holds, but they are not triggering any routines (For some reason the Kyse one does not show any option to add hold when using apps like smart lights.) or smart apps like Smart Lights.

I know this remote has been mentioned before, but the workarounds do not seem to work. Is their any newer info on this to getting it to work. I would love to have this work as Local too, but right now just having it work would be nice.

Any new feedback to this remote, and newer better device handlers would be welcome. Oh and for any programmers, it would be really nice if the blank button next to the Join button could be used as a Panic Button.

The blank button doesn’t have a label, but that doesn’t mean it doesn’t have a function. The four buttons inside the case are used for administrative tasks. The blank button is used for association. So you can’t assign it to something like a panic button, it already has a purpose. You could use one of the buttons on the outside case, as those are user assignable. But the buttons inside the case are determined by the firmware from the manufacturer and cannot be changed. A lot of people were confused by the blank label, which is why the newer generations of the device do label that button now:


As for the problems you’re seeing, i’m sure that’s very frustrating. :disappointed_relieved: The minimote is one of the most popular devices and many people have them. There were some recent changes to the stock device handler, so I think the best thing is probably to get in touch with support and see what they say.

1 Like

Thanks for the update.

I would really love to see Aeon offer a firmware update to this that made it into a simple 7 button remote (local control) that offered: 4 buttons programmable, + = Arm system, - = Home, and blank Panic alarm. That simple update would make it the best SmartThings device period, well providing they could get it to work reliably.

Have you had a chance to look at some of the other button remotes that work with SmartThings? There are quite a few button devices now that offer eight or more options:



I just wanted something simple that worked with Smartthings and Local Control. I just tried removing the remote, then resetting the remote and adding it back with the Kyse handler. Everything worked fine with that including programming several buttons, but for some reason it would not give any option in Smart Lights or other apps for long button presses. So then I tried removing removing the remote again, deleting the Kyse handler, resetting the remote and adding it back in under the default local handler. Once again ST added this fine and I could access push and hold options, but now nothing will work again. Strangely though ST sees the button presses and the button holds. Arghhhh

There were some changes in some of the Aeotec stock device handlers around September 1 which meant they won’t run locally until the firmware is updated again. (edited to note it looks like the minimote, at least, may be local again) The other DTH never ran locally because it’s custom code and no custom code runs locally at present.

Also, there have been some significant changes in how smart lighting works since the Kyse device type handler was written, in particular the use of “number of buttons” and I’m not sure that DTH was ever updated to work in the new way. But questions about that device type handler should be asked in the author thread for that code.

Because of the recent changes to the stock device type handler, I really think you need to talk to support. There has been some weird stuff going on.

Pass. In IDE Devices, Smartthings reports the Aeon Minimote as running locally with the stock handler. If I use the Kyse one then it reports that as cloud. Even so, non of them will reliably work with anything from Smart Lights, Routines, or the smart app minimote.


Using the stock ‘Aeon Minimote Handler’ In smart lights and other routines I was selecting the button number (i.e. Aeon Minimote button 1) in the ‘Which Button Option’ for the remote, then selecting press or hold in ‘Button Action’ option. Apparently I needed to select just the ‘Aeon Minimote’ at the top of the ‘Which Button List’ list ignoring the 4 button options below. When ‘Aeon Minimote’ is selected a new option appears to select a button number, then after that you can select press or hold. When I did this, I had to wait a couple of minutes for the smart light app to update, but now everything works fine. Yay As mentioned at the beginning, all this is working locally too, so no need to use the KYSE Cloud handler.

Excellent. I suspect this is a change because of the September 2017 changes to the stock device type handler which now treat this as a composite device. So you are needing to select the parent before you select the individual button. Given that, it probably shouldn’t allow you to select individual button first, since as you report that isn’t working, but I’m not sure if that’s possible or not in the new structure.


Yes in the ‘Which button’ it lists the remote as a Parent and the other buttons as a child directly below it. I did once get one child button to work but never more than that and it as never reliable. So I am hoping in the future they remove all the child button options from that ‘Which Button’ list to stop confusion.

The only part I do not like now is the remote button seems to save its own state, as if on or off, when the device handler should read the state of the hub to see if a light and so on is on or off. It is strange how we have to sometimes press the button twice to turn an item on.


If anyone else has had trouble with their minimotes since the update last week, the fix for me was to open the device configuration page in the mobile app and save it again. This will register all of the right attributes. Hope this helps someone.

1 Like

Is anyone currently able to use their Minimotes to pair/unpair zwave devices to/from ST? I bought the Minimote for this reason, but it doesn’t seem to work. @JDRoberts, do you know?

It used to (I’ve used it myself in the past), but I haven’t used it for that purpose for a while.

I’m not sure with the current situation is.

Did you try the method in the FAQ? (This is a clickable link)

Sorry if this is dredging up an older topic, but the title is Minimote headache, thats what I’m suffering!

I cant seem to add the minimote to ST.

I’ve tried a general exlusion and the flashing indicators on the MM dont seem to indicate what teh MM manual is telling me.

I have done a factory reset too on the MM. No joy. The ST app just seaches and searches.

Then i thought I’d update the firmware, and the downloaded .exe file when opened doesnt see a minimote plugged in :frowning:
ALthough this could be the USB cable, ill try another mini USB tomorrow (i dont have the original)

All seems a little stange, any advice?

PS its an EU minimote, and im in the UK.
Its a V1 (no numbers)
Its a V2 ST hub


Yes, in fact that was the exact link I referenced when I was struggling to make it work. Alas, no go. I also emailed ST support yesterday—we’ll see what they say.

In the meantime, can you or anyone who has successfully done this in the past, give it another quick go?

Hmmm, I didn’t expect this response from ST support today:

Hello Mark,
Thanks for your note – I’m happy to help! Sorry for the trouble using your Minimote.
You are correct that a Minimote can be used to exclude Z-Wave devices for use in SmartThings, but you will not be able to include anything to SmartThings using the Minimote. If you would like to use it as a controller, then you would need to contact Aeotec for support (and you wouldn’t be able to use those devices in SmartThings).
You will need to a long Ethernet cord and/or repeater devices (most any Z-Wave devices that plugs into power) to pair devices after you’ve excluded them via the Minimote.
Let me know if there’s anything else I can do to help!
SmartThings Support

This is the first I’ve heard of this. Can anyone corroborate?

Tagging @duncan

So, the saga continues. After indicating my surprise to ST support about their initial comments about Minimote not being able to include zwave devices, they send me this “clarification” the other day:

I’ve taken a look at that thread, and apparently it is possible but it’s NOT recommended or supported … and would be a “proceed at your own risk” type of situation as you may inadvertently turn your Hub into a secondary controller. Sorry for any misunderstanding there.

Can anybody confirm that they are currently able to pair a zwave device from their Minimote? And, if so, how do you do it? To be clear, I have no problem pairing the Minimote itself as a thing. I’m talking about using the minimote to pair other zwave devices.

You never know if the SmartThings platform has introduced some strange idiosyncrasy, but that reply from support seems confusing in a zwave context. :disappointed_relieved: Once the minimote is added to your zwave network, using the stock DTH as a supported device, then it becomes a portable controller. That’s its function. It can’t hijack the network and turn the hub into a secondary. It will either be able to include devices, or it won’t, but it’s not going to affect the hub’s status. Again, unless smartthings has done something odd that they never used to do before.

And it was never “not recommended or supported”–it was in fact the recommended method for working with light switches that needed to be paired in place but were more than one hop from the hub.

So either that particular support person needs some more training or, like I said, they’ve changed something on the platform side, which is always possible.

@tpmanley might know.

( I have a minimote, but I’m not physically able to use it, and my techie aide doesn’t come until Tuesday, so I can’t do the test myself. )


Whatever the topic in this community, you also seem to know two and a half craploads about it. Props to you, sir.