Aeon Labs Multisensor Gen5 - Not Connecting Properly

Hi All,

I just purchased an Aeon Labs Multi-sensor (Gen5) and when I select "connect a device " in the Aeon Labs Multi-Sensor tab under “Things”, it says a device has been found but not the correct type. It does shows up as a generic Z-wave device but I am unable to configure any of the sensors.

After speaking with Smartthings, it appears that Aeon Labs has changed their chipset and the Z-wave Generation 5 is not yet supported on this platform.

Has anyone had any luck pairing the Gen5 version of this sensor?


1 Like

Where did you buy a G5 at? I did not even realize they had a new multi and it’s not on their website.

@JB872 if it’s Gen5/Z-Wave Plus it probably needs an updated device type for the secure part of z-wave plus. A few Aeon Gen5 devices are working with updated device types. I don’t think there is one for this yet, but I’m sure it won’t be long.


I believe you need to add the security command type to the existing device type. See the following:

1 Like

Haven’t heard of Aeon Zwave plus multi in US of A. I have a 5th gen. Aeon Siren which works thanks to @duncan. Don’t have the recessed doir sensor but @beckwith is right as I read it too.

Hi Ron & beckwith,

For someone who has little experience with Smartthings platform, is it a difficult task to add the security command type to the existing device type?


I so wish I could help with this but I am in the same category as you. I follow this community and learn. This community is the new Facebook for us…:wink: as far as I am concerned SmartApps may be but device handlers… I will definitely brick it for you if I tried!

I would ask @jabbera how he added gen5 to the recessed door sensor.

Here is another device that a community member added the secure part to the device type to make it work.

It’s not terribly difficult. I’ll try to get to it today.

1 Like

Thanks Jabbera. I changed the device ID and was able to get the hub to recognize the Multisensor but it is not reporting any data.

I’m trying to make the modification but the website will not let me make a new device type from code. It keeps timing out…

Try this. It’s totally untested since I don’t have one.

Hi Jabbera,

Thanks for taking the time to look into this. Unfortunately I wasn’t able to connect and I was wondering if it has something to do with the Gen5 having a different raw description.

Raw Description 0 0 0x0701 0 0 0 11 0x86 0x72 0x5E 0x59 0x85 0x73 0x71 0x84 0x80 0x30 0x31 0x70 0x98 0x7A 0xEF 0x5A 0x8

For the door sensor even though the thumbprint was different you could just change the device type from the dev API and it worked. Have you tried that?

I tried changing the device type to 0x0701 and I was able to connect to yours but it is not polling any data. Is there anything else I would need to change?

I’m new to this but try changing the device type

fingerprint deviceId: "0x2001", inClusters: "0x30,0x31,0x80,0x84,0x70,0x85,0x72,0x86"

fingerprint deviceId: "0x0701", inClusters: "0x86,0x72,0x5E,0x59,0x85,0x73,0x71,0x84,0x80,0x30,0x31"

Thanks mattjifrank but still not displaying data

Unfortunatly this means the change is something more involved that I can’t make without an actual device. Sorry.

The fingerprint only deals with detection of the device. It doesn’t change anything about the device functionally. I don’t worry about them until I have a working device type.