Aeon HEM v1/v2 Firmware 3.64 Numbers are Off?

John would you please send me a link to the one without battery? Thanks.

No problem!

https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-aeon-home-energy-monitor-no-battery.src/my-aeon-home-energy-monitor-no-battery.groovy

I can’t figure this out my HEM V1 is showing everything correctly but not sending data to ST. I don’t see any watts on the logging page. but when I click on recently it shows logs. Any ideas? It was working yesterday as it updated the Google spreadsheet.

The data is really in ST because the app wouldn’t update unless data changed. My DH stops flooding the device’s Recent Activity tab, and event log, with data unless min/max values change, or if it’s reset. That was a request I had almost a year ago from many, many, users. It still sends data to Google spreadsheets, it just doesn’t flood logs with tons and tons of event history.

Are you no longer getting data to your spreadsheet, and what app are you using to update your spreadsheet?

I get no updated watts sent to Google but the app on the phone is updating. I am using Simple Event Logger. Below is a screenshot of my IDE page please check settings. It stopped logging at 1.30 Pm today. I changed DTH, but put it back, so can’t figure out what I did. Is the voltage set right for a 240 volt two phase panel?

There’s a difference in how @krlaframboise’s app sends data to Google vs what’s done with another Google Sheets app and other apps like Grove Streams.

Because of those differences, my DH won’t work for you unless you want to use this SmartApp:

That app doesn’t provide the same amount of data as Simple Event Logger. There’s another person he’s working with on exactly the same issue, and considering this app does a lot more, I’ll have to look into what I can change in my DH to make it work with his smartapp. Stay tuned.

1 Like

Thank you that will be fantastic.

Cool. I just PM’d @krlaframboise to see what we can do.

What DH were you using before moving to mine? DO you still have a link to it or the github repo?

1 Like

No I was using the one without battery I only have a copy on my drive. But I tried using that no luck.

@ethayer/Erik - regarding above to clean up parameters could you answer a couple questions?

First, very basic…after I add the line to the config section, how do I make it do its magic?

Just add the line, save and publish and let the HEM sit for a few moments, or do something to it via the SmartThings app?

Second: I’m actually using a different DTH for my HEM as I’m using to read/report the two clamps separately. From this thread below. Can I add the line to the config section in that DTH, or would I have to use your DTH to accomplish the reset?

Thanks!

I tried that DH and I couldn’t get anything but Watts and KWH both on the right side one on top of the other, nothing else would show just dashes. I am not sure what the problem is but on my iPhone not a thing.

Yeah, I was just going to see if the config clean-up from the added line that Erik suggested helped w/the remaining issue w/the other DTH - that it won’t calculate energy cost. Thinking that since I’ve upgraded/downgraded FW on the device a few times things may be messy. :slight_smile:

I was hoping that DH would work for reading clamps separately but no luck for me. Maybe someone will refine the code, I can’t be the only one having problems. But maybe I am.

Anyone notice these not reading zero properly? I have one device on my dryer and the draw is 0 when it’s off but it consistently reads 3.08w. I’ve tried a second hem with 3.64 vs 3.60 and get the same result. All my other hem’s are on devices with a few Watts draw minimum so I don’t see the issue there.

I use the default DTH with some minor modifications. That DTH reads 0W for my dryer. When using other DTHs I also saw the 3.08W number.

1 Like

I’m guessing it’s related to everyone else’s DHT trying to avoid null readings. Maybe? I get that, the intent of the device is whole house monitoring so a reading of zero is unrealistic.

But with my logging system, the last reading is carried until the next, so a zero reading is important to not have the 3w reading for hours or days between use.

I’m assuming you’re using the dual clamp DH and not mine?

Yours, no battery version actually.

Ok. There’s a line of code that looks like this:

if (newValue <= 0) {newValue = state.powerValue}

If you change that line to this:

if (newValue < 0) {newValue = state.powerValue}

Does it work?

The assumption was that as a whole home meter you shouldn’t see zero, and definitely not less than zero.

Yes that was it! Published the change and instantly went to zero! Thank you, that has been bugging me for a while!