Aeon HEM v1/v2 Firmware 3.64 Numbers are Off?

I updated to firmware 3.64 as it did not say was for v1 verse v2. It updated but after doing so the numbers got huge? I am just guessing but seems like to get to more realistic values have to bring down 2 decimal places (i.e. value / 100)?

http://aeotec.com/z-wave-home-energy-measure/1262-hem-firmware.html

I like to know if that was a correct guess, but really just want to know how to scale to get correct number readings again.

I even settle to downgrade firmware, but those files are not listed…

Emailed Aeon tried frimwares 3.41 through newer (not listed) 3.46 and nothing. So they simply suggested returning so I shall.

Do not upgrade the v1. I was hoping by upgrading would get some of the v2 features and or fix any bugs in v1. Answer was no…

@justinlhudson I have HEM v1 and it’s also posting huge number i.e. 230kw.
Do you try the older firmware?

I installed v3.61 and it seems to have fixed it. I found this post which was helpful:

1 Like

@frayes I just emailed them and they gave me several to try. End result they suggested was to return the item for replacement and to never update :slight_smile:

Does anyone have a copy of the v3.61 firmware? I could use it.


Relevant link from the blog post that @frayes posted:
https://systembash.com/wp-content/uploads/2015/02/HEM361.zip

NOTE: I do not recommend this approach to fix this issue, as it doesn’t seem to be the true culprit. Please see my next post.

1 Like

Here’s what worked for me to fix HEMv1 ludicrous numbers:
https://raw.githubusercontent.com/ethayer/AEON-HEM-v1/master/AEON%20HEM%20v1.groovy

I added this line to the config function:
zwave.configurationV1.configurationSet(parameterNumber: 255, size: 4, scaledConfigurationValue: 1).format(),

What does it do? It sets all parameters to the factory default. Seems like after upgrading or downgrading the firmware, some parameters become… wrong or missing. This fixed it for me.

##Note if you have this problem on HEMv2:
Change size:4 to size:1, so that the line reads like this:
zwave.configurationV1.configurationSet(parameterNumber: 255, size: 1, scaledConfigurationValue: 1).format(),

6 Likes

Thanks @ethayer, that worked for me too.

I just want to repeat what was pointed out by another ST member over on a different thread. After you’ve included the config reset argument and the HEM has been reset to factory, the line needs to be commented out or removed all together. Otherwise, all other customized device settings like polling interval will be effectively ignored.

Erik, I know this thread is waaaaaay old but do you think it’s okay to upgrade firmware on HEM V1 as long as afterwards I add the above line to reset config? Or, maybe a better question is, will upgrading V1 HEM firmware gain anything (accuracy, features, etc) anyway?

Thanks, jd

Speaking from experience and doing this myself - nope. I have the latest firmware, but every so often I’ll get a reading like 12472634590W (or something gigantic like that), which is what I thought the firmware should have resolved. Yes, I also did the reset to factory default.

I also have this happening on the Aeon Smart Switch (gen 1):

Speaking of HEM, have you noticed by any chance your HEM reading higher in the past several weeks? I have not done anything differently or added new electronic devices, but I noticed that reading jumped from 300s in standby to 900s. I haven’t actually started any investigations, yet.

Yes, only because my daughter is back from college and she’s plugged all her crap back in. Typically I’m in the mid-300’s range, and with a few more things plugged in, I’m still in the high 300’s.

1 Like

Ha, mybe my son’s girlfriend moved in and he forgot to tell me.

I found the problem! It appears that I have accidentally turned on my heat pump’s fan, instead of keeping it on auto. Fat fingered the settings on the t-stat DTH UI. I cannot believe how much power this thing uses… It’s nice to have a HEM. I would not have noticed the accident.

1 Like

which dth is recommended for aeon hem v1? i can’t tell which is most recent feature packed version.

I’m a little biased toward mine for the HEM v1 :wink:

What’s your phone’s OS - Android or iOS? Right now on Android there are some display issues with tiles and text alignment. I think on iOS it’s fine.

https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-aeon-home-energy-monitor.src/my-aeon-home-energy-monitor.groovy

3 Likes

I gotta say that I went through several different DTH out there and @johnconstantelo DTH is what I’m using now and I think it’s one of the best.

1 Like

Agreed that I have been using @johnconstantelo for over a year and this post just let me know that an updated version was available :smiley:. Once questions for you John, any idea why Configure might not be working on Android?

@johnconstantelo

I hadn’t updated my DH in a while and updated to the latest. I seem to be having some display issues. The font is tiny and I don’t see a max value - shouldn’t it be there? Also can’t see the dates for the reset line

Anyone else look like this?

Hi @penguin22,

When you mean not working, do you mean it’s not changing the parameter values to what you set under Preference? This is what Live Logs should show when you tap on Configure: