Aeon HEM v1/v2 Firmware 3.64 Numbers are Off?

Hi @penguin22,

When you mean not working, do you mean it’s not changing the parameter values to what you set under Preference? This is what Live Logs should show when you tap on Configure:

I just updated the DTH, and you’re right, I get the same results. This is on my iPhone running iOS 10. I checked the preferences and all the fields are populated. Previous to the update, the DTH was working great, is there a way to go back a version? I just checked my Android phone, and the new DTH seems to be working fine, the font is larger and the cost has a dollar amount.

Depending upon which earlier version you had, you may need to reset values because I’m using new attributes and variables. From what I can see, it does look like a reset on all three should be done.

Unfortunately there’s not much I can do with fonts and some other UI features. It’s all related to our phone’s OS and how different the ST app handles each one. You’d think they’d look the same, but they just don’t. For example, on Android everything was great until the latest release screwed up text alignment:

I have tried resetting all but no luck. I will look into it more. Strange indeed but thanks for the info!

Very odd. Keep an eye on your Live Logs for any errors and let me know. It’s very frustrating that ST’s app constantly throws curve balls at us for things like this. If I fix something for Android, it breaks iOS, and visa-versa. @Jimxenus’s post above is another great example.

@Jimxenus, unfortunately there’s no way for me to know which version you were using. Unless you made a copy of the DH before updating, it’s going to be practically impossible.

I did find an older version that I’ve now installed and it seems to be working although the one I used previous to the latest update was newer than this one because the preference settings are just numbers without any explanations of what they do. It does look better for iOS. I could upload the code if you want it.

Clicking on the Configure button does nothing. It never opens a configure menu at all.

Config button not working for me either on fresh install with hemv1.

@johnconstantelo - is there a thread for your DTH, it would be nice to have a specific place to find your latest code and discussion.

1 Like

@justinlhudson, out of interest, how do you actually get the new firmware to the HEM?

AFAIK, ST doesn’t support over-the-air firmware updates to z-wave devices… do you need a Zwave dongle attached to your PC?

It doesn’t open the config menu - it pushes the config to the device I believe.
The config properties are set when you edit the device - top right corner click gear

1 Like

I have left the firmware at the version that came on the HEM as there were differing reports of functionality and it is functioning fine for me for over a year now.

This would make a lot of sense, so you have to edit the code and then open the device and hit config for it to be sent to the HEM.

Yes open the device in the app and click the gear (now in the IDE) - after that you set the parameters you want. When that is done you push config and it pushes that to the HEM

My “new to me” HEMv1 has mini-USB port. For my Aeon mini-motes I went to their support site, downloaded firmware update file. It is a windows exe that finds the mini-mote on USB and updates it.

1 Like

Good idea, here it is:

1 Like

Didn’t even realize there was an update. Missed this thread entirely. So the consensus is not to upgrade firmware on v1? I get random 20k readings, rarely, but it’s irritating, so this won’t fix that? This is why I like graphs:

That little red blip masks the fact that I use from 1-3kw, with the average being around 1k:

I still updated the firmware and I still get wild numbers, so I tweaked the code for my DH to look for anything larger than 10000. I thought that was a reasonable value to check against based on my home.

1 Like

is that configurable or do I need to go into the DH? I sometimes have a load over 10k so I will need to bump that up. My wild numbers are in the 200,000 usually

For now you need to just modify line 201 (or around that line number), but I can add another parameter to the DH so that you don’t have to modify code. I’m actually tweaking it now to add comments and code for iOS users to use instead of the ones that work for Android. I’ll post an update to the other thread I created earlier for my DH.


John would you please send me a link to the one without battery? Thanks.