ADT security hub keeps rebooting

Hello there,

We have an ADT security hub, I have been trying to boot the device, but it keeps rebooting after checking for update and have been stuck in this loop since now.

All I have done this far, is connect the wifi network, once it keeps checking for update it reboots and so on.


1 Like

i am facing exactly the same issue , hangs on ‘Checking for update’ for long time and then it reboots again.

maxrh: Did you find a solution for that?

Hi Sayef,

Yes i was able to solve the issue, after contacting ADT it turned out that this product is region locked to USA, so u have to at least initially connect it “via Wi-Fi” to a VPN network from the US, it will start downloading after checking for updates, once it starts you can disconnect your VPN.

Hope this helps

I do connect my wifi to vpn in the usa but not working still stack
also contacted with support they tolled me it’s not supported from outside usa

please help

yes, same reply from samsung ADT support: product should be first activated in USA. Case opened with amazon and they apologized they did not mention that in product description and offered to return the item and refund… this is not an option for me as shipping cost for receiving the starter kit and expansion pack is like 100$, sending it back will cost even more :(.

Trying the VPN connection now, but it is not working :frowning: , i am using mobile hotspot and i have USA VPN activated on my mobile, ADT hub is connected through wifi to the mobile but still facing the same issue.

maxrh: how did you do the VPN connection exactly? , thx

I tried to add vpn to my mac and after that share connection other devices conected and when check ny ip is in usa
But no thing happen to adt hub its connected to wifi but bo thing happen!
Please tell us how do you get it work

I used wireshark to analyse network trafic in vpn server and got that adt hub trying to query dns servers for
file://dev/null to which is no reply form this server or dns

i am not a network specialist so any one know what is this ?
and how to fix it

ejasoft: Did you manage to solve it?

No, still trying to found a solution
If you have a luck tell us
Thank you

Any update ?

Im also having this problem, wondering if a “Residential VPN” will work.

Iam tried vpn “ openvpn servers” and serivies like vpnshiled “ but not work

Still not working… :frowning:

i read that vpn connection from mobile (hotspot) will not work, so dont try that.

yesterday i configured wifi shared internet from laptop & activated VPN on the laptop but still not working.

will update you if i succeed to do it & please you do the same.


Hi all,

you need to use hotspot from your PC not your phone, and you need to share your connection from your VPN new adapter to your wifi adapter in your PC in order to use the VPN connection via WiFi

I tried that also,
Could you please tell me which vpn you used ?
Application or server which type of vpn

Thank you
Best regards

Hi @ejasoft, I didn’t use a specific service, actually I used one of the servers provided by using the built in VPN in windows 10, after you connect and enable hotspot in windows 10, you need to modify you adapters to make sure your WiFi hotspot is shared from the new VPN adapter.

Edit your VPN adabter and make sure you choose the hotspot adapter from the shared tab.

So you have fully activated this using a USA VPN service ?

I have tried a few but none of them work despite me checking the IP on another wifi device and it was 100% American.

Do you have details as to which VPN you use from ? im thinking it needs to be a residential based USA address.

I am not sure, but i think i used the “Miami” server

What program did you use to connect to the VPN ? if you dont mind me asking :smiley:

No program, Just use the VPN service in windows 10:
Settings --> Network & Internet --> VPN , and add your own preference