Adding New Devices don't Find Edge Drivers

Approx 2 weeks ago I joined the Edge Beta. I was successful in changing a few devices over to the edge drivers. Last night I tried to change 2 devices (Sonoff SNZB-02(Ewelink TH01) and a Samsung Smartthing Leak Sensor. No success, they get added but with the original dth’s. Could this be due to the Smartthings app latest update for android? Any suggestions?

If you were using Custom Device Handlers previously… you would need to remove those from IDE or remark out the fingerprints in them in order for the pairing to get the Edge Drivers.


Thanks @jpk for your suggestions as I was able to add the Sonoff SNZB-02.

Onto my next devices with no success

I removed my custom device handlers but unable to add devices. I delete them and re-scan but they always re-install with the old(non-edge).

I did find the fingerprint and installed the drivers?

Process I’ve tried

  1. remove device via Smartthings app(Android)
  2. close app, clear cache
  3. Installed driver
  4. re-booted hub
  5. Scan for devices
  6. Device found and auto added with the non-edge driver

Any suggestions?

Update, able to get devices installed with driver.

  1. Delete device from IDE, not app(android)
  2. Remove battery from device
  3. Install battery and try to pair

I’ve had the most success with these steps