Adding devices

Just decided to add a new device today. When I added it, device came back as ZIGBEE Thing. I went on to my computer to check my device and make sure the device was working properly and it is not. Doesn’t show the zigbee network id or the network device id. I have other device the same model that are working fine. I have tried 3 new sensors with the same results. On my phone with the app it just says online and thats it. Any ideas that could help ???

I’m sure that’s very frustrating. There were some recent platform changes regarding DTHs that you might have run into. :thinking:

What’s the Brand and model of the device?

Visonic MCT-350

I have some working fine and see the Zigbee ID’s but when I add another one it will not show up.

When you say you “checked your device“ did you use the CLI or the API browser plus? Those are using the new architecture.

If you try to use the IDE, that is part of the old architecture, any information there will be missing or inaccurate.

Life after the IDE: Questions and Answers

I went into the IDE and seen that the ZIGBEE ID stuff was missing. I just tried that link you seen about the life after and still do not see a way to get it too work. Totally frustrating for sure

install the Zigbee Contact MC Edge driver on your hub. Then either pair the device again or edit the existing one in the ST app… open the device, tap 3 dots, look for Driver and from there you can choose the new Edge driver after you install it. If Driver does not show then it is using a DTH and you would need to remove and pair again so it gets the Edge driver.

channel invide for Zigbee Contact MC

start using API Browser+ instead of the legacy IDE - especially for devices using Edge… do not use IDE for them.

1 Like

just did…and it works !! Thanks so much