[BETA] Z-Wave Tweaker (See post #209 for new V3 app version)

Thank You. I will try again. I think I was just trying to say that I am not able to scan and print (sync) as described in most of the text within the community on this subject because the Tweaker with the tiles that you can scan and print / sync do not show up due to the New App. Specifically, I am talking about the tiles including the General Scan, Associate Group Scan, Endpoints Scan, Parameters Scan, Sensor Scan, or any of the associated Print / Sync Tiles. I assumed there was some benefit to Scanning and Printing/Syncing associated with the tiles.

So it sounds like I can use the Tweaker on the Master Switch and or Accessory Switches for association. For some reason, I thought I had read that you always use the Tweaker only on the Accessory Switches. My Bad.

OK. So I should be able to add the Association Group ID of 2 and add the Network Device ID’s as Associate Group Members and should be good to go. Are there any other settings I need to update?

not for this scenario - if it works you’re good to go.

It can definitely get confusing. :thinking:

To set up the basic three-way, you only use the tweaker on the accessory switch. That’s enough for many models.

Some models, like the one you have, may run into the problem of the accessory getting out of sync with the master, which is why you have to press it twice.

In that case, as discussed in the other thread I linked you to, you have two choices.

  1. try setting up an association in the other direction. This works with some models. It doesn’t work at all with other models. And with still other models it will put the devices into a loop. So you can try and see what happens.


  1. Use the “mirror“ option in the official smartlighting feature to have the accessory follow the master, thus keeping them in sync. Instructions for that are discussed in the other thread.

I took a look at this tweaker again as the topic came up in another thread. It seems it can still set assocations and parameters, and log some basic info at initialization, but the ability to scan available associations and parameters no longer works in the new app. Those actions were all controlled by tiles that only worked in classic app. It looks like the DTH would either have to be written to put those tile actions into preferences, or create custom capabilities with the CLI to create buttons/toggles to activate them. Anyone have any luck with a workaround to get those scan options working short of rewriting the whole DTH?

1 Like

Everyone is looking at you @mwav3!

1 Like

Lol, open mouth insert project. I’ll see what I can do.


Someone on Github mentioned using the simulator in the IDE to activate the tile actions, and it worked. I was able to do all the tile actions and scan association groups using the simulator. Condidering you wouldn’t use this DTH permanently anyway, this is an ideal solution versus rewriting the DTH.

1 Like

Thank You for taking the time to look into this. I also had the New App vs the Classic App. After a lot of trial and error and working with the community, I was able to get the switches working. I stumbled across the tiles, as you said, by using the simulator in the IDE to activate the tile actions. However, I was not able to confirm the tiles worked correctly in the New App. From a switch standpoint I discovered I was only able to use the Eaton 9617 Accessory switches when I needed a 3 way switch. In all other connections, I had to use the Eaton 9601 Master Switch.

I found some limitations to the simulator workaround I posted above, where you couldn’t easily specify ranges for parameter and association group scanning that way.

So, I ended up doing an update on the tweaker that took all the old tile actions supported in the classic app, and added toggles for each one in the preferences screen to trigger them that way instead. I sent a PR to @zcapr17 but I don’t believe he is actively maintaining this code anymore. You can get the code that will now support all functions in the new smartthings app from my fork of the project at the link below:

When you are done using the tweaker and ready to go back to your default device handler, you should perform a cleanup by toggling the “Perform Clean Up” setting to remove unnecessary settings from sticking around in your device. I put the cleanup at the top of the preferences.

Al the commands triggered in testing - sometimes I did have to do it twice to get the logs to generate though. You should also make sure you change each one back to false before moving onto another one or any toggled “true” ones will run together. The cleanup will clear all these preferences back to “null” but you would have to leave the screen and come back to see the update.

Screenshots (these are all from the preferences settings):


Bless you, my son! LOL! :innocent:

But seriously, that is an outstanding contribution to the community. Nice work. :clap:t3::clap:t3::clap:t3::clap:t3:



@mwav3 I could tell the Force was strong in you young Jedi.


Wow, well done, thanks a million :pray:

1 Like

Hey Tim,

Having some trouble pulling the modified device handler from your mwav3 GitHub repository SmartThings-1 directly using the IDE. When I update from repo, I don’t see anything in the New column. I can just copy the code, but I wanted to link it in case you’re actively working on it.

I’m not really sure what the “protocol” is if any to takeover someone else’s code.

I’ve taken old code over and put code in my repo where the developer said it was OK for me to update, I made so many changes the code was significantly different (with notes saying “contains code” from the old developer and thanking them), or the developer’s github is dead and they are totally unreachable.

Codersaur has posted to his github within the past few weeks so is active, even if not supporting Smartthings anymore. I also just made minor updates. To put it in my repo I have to say I’m the author and I just dont know if I should do that.

For now it’s just in my fork of the project, but that can’t be imported as a repo as u pointed out above. Anyone want to chime in on the best practice here as far as me posting this in my repo?

1 Like

@glenmm, did you sort this out with @mwav3? I also had the same issue with the repo as it doesn’t see any of the devices including this one.

No, I basically just copy-pasted to update my DTH

The Z-Wave Tweaker always did have to be copy and pasted as the repo wasn’t in the format that the IDE looks for. Using ‘Commit changes’ to upload the DTH to a repo would upload it in the expected location (which is roughly speaking devicetypes/namespace/name-of-handler.src/name-of-handler.groovy but it really is best to let the IDE do it to get the case and hyphenating right).

@orangebucket I know you’ve been developing on here for awhile. Is there any issue you think with me putting this code in my repo for other’s to import? I still haven’t put it in my own repo, which as you pointed out above would be required for direct import in the IDE. However to do that I have to publish it as the author as if I wrote the code, and I don’t know if that’s ok since all I did was a simple update. I mean I would of course give credit to @zcapr17 in the code, and it is open source, but I still don’t know the protocol on that and hopefully you can provide some opinion.

In the meantime, I still have the DTH code in my fork of the project and plan to keep it there at the link above - also here’s the link to the “raw” file on Github which may make copy and pasting easier for direct import into the IDE
Anyone is free to use and and make any changes you want- which goes for all the other DTH’s/code I have listed. I didn’t put it out to make any money and just wanted to give back to everyone on here for being so helpful.

Unfortunately though I’m not using Smartthings anymore and once the IDE is phased out I don’t think this code/import method will work (hopefully I’m wrong). I mean if it’s a “simple” update I’ll try to help out but if it requires a complete rewrite I won’t be able to keep up.

1 Like

I really can’t see any issues at all. The original code is covered by an Apache licence which pretty much means you can do what you like as long as any original code is still covered by the licence and you make it clear what has been changed.

There is no technical reason why you can’t retain the original ‘namespace’ and ‘author’ but also no reason why you shouldn’t use your own if you think that more appropriate on an ongoing basis. It is not just about credit, it is about avoiding confusion.

1 Like