A problem of my own making... Errrm, help!

Folks, I successfully configured a Life360 connection as per this link: https://support.smartthings.com/hc/en-us/articles/202334244-Connecting-Life360-with-SmartThings

I had everything functional, and then I started wondering if I could set up more than one Live360 (Connect) SmartApp… And as they say, it was all downhill from here…

What I did was copy the code from the Life360 (Connect) SmartApp, and past it in as a NEW “from code” SmartApp, making a slight name change. This worked, the Smart app was added successfully, so I did it again; after all 2 is better than one eh?! See screenshot below, and section of code I modified to do so:

My ORIGINAL Life360 SmartApp, when configured, also set up a new device that I could install…

I soon found out when trying to configure the 2 “new” Life360 SmartApps on my Android device that they failed with an error:
“You are not authorized…” etc.

Then I deleted the BOTH the ORIGINAL device and SmartApp… Bad move me thinks…

I then tried deleting the 2 new Life360 SmartApps from the IDE. Cant do so from within the Android app because I always get the error “You are not authorized…”, and the IDE gives me this:

And there ya have it. Any really SMART, not to mention COOL, people want to try to fix this??? [My shameless plug at flattery]


Just for the record, my hub was also updated today to Firmware 000.014.00026, and it has made no difference with deleting the SmartApps. [I was hoping…]


In the IDE

My Locations -> List Smart Apps

Is it listed there? If so click Edit (under the banner) and click uninstall.
Then you should be able to delete the custom app


Hi Kevin

You, Sir, are SMART & COOL!
Worked like a charm!!! Much obliged.
[Truth be told I knew about it in as much as reading about it on this very forum; now don’t go asking silly questions why I didn’t try it!! :slight_smile: ]


Not a problem. The one thing I wish ST had here was a FAQ for the common questions like this. It tends to come up often. The hard thing is sometimes finding the write terms to find what you’re looking for

There is this that members of the community created. Looks like this needs to be added there too


I just tried this with one that has me locked and it will not uninstall. I have tried removing it from the App and it says “Unexpected error” I tried with your directions above (thank you by the way) and it will not go Any other things I can try?

When that fails, you’ll probably have to go through support