3M-50 Wireless Thermostat

You shouldn’t give up because it should totally work. Try putting the hub in Z-Wave remove mode then clicking the link button and see if the USNAP modules were removed. If it works then try pairing again.

@urman thanks this is exactly what the problem was. Since I purchased this device used on Ebay it was already paired to another ZWAVE hub.

However, per ST technical support I logged into ide.smartthings.com to try and put my hub in exclude mode. I than almost instantly began initiating the command from my thermostat to try and send it the exclude command. It would never work. Luckily I had an old cheap battery ZWAVE controller laying around. I was able to send the exclude command from this device pretty easily and it worked instantly. I then was able to include the ZWAVE USNAP module on my ST hub.

Thanks again for all the tips!

ah sorry @jeremywhittaker the Z-Wave Exclude button on the IDE is broken :frowning: Slated for a Monday fix.

@urman LOL. Thanks! You should let support@smartthings.com know that! They were the ones who suggested last night that I give it a shot!

Either way it’s fixed now and I’ve got all my devices online! Now I just need to setup all my automation tasks and verify they’re working.

i got my 3m50 online with the help of this topic, but it doesnt update the temperature in real time. im assuming bc how the firmware, i was told by radio thermostat, doesnt support zwave. has there been any problems for others controlling 3m50 with their ST?

@rangelsammon the USNAP Zwave module in my opinion is worthless. I have the 802.11 wireless USNAP module in which I can control the temperature from my filtrate app. However, in my opinion the Smartthings Zwave USNAP module is not completely working. Not only that I personally feel like it is the cause of other communication issues(wirelessly) between my hub and other devices. If you search the internet you will notice other people who have similar experiences. Go with the other wireless USNAP module and just cross your fingers that Smartthings integrates this one into the system at some point. There is another forum topic that discusses this module and it is possible. It’s just a matter of when they will do it.

u have a st zwave usnap? i dont they make bc radio thermostat is the only maker of these usnaps. i bought my usnap on ebay and it was made by radio thermostat. it works but sucks bc it doesnt sync real time the temps. i may have to buy ct30 or 100 so i can have that capability to run other commands based on temperature.

@rangelsammon no, I have the same usnap module made by radio thermostat. What I’m saying is that for whatever reason integrating that into ST has never worked properly IMHO. It’s so bad that I pulled the module from my thermostat. I found that for whatever reason it caused interference in my system and my other wireless devices were having issues with it online. I also have the wireless usnap which works great. However, ST has not yet taken the time to interface the API of the wireless usnap. They have only done the ZWAVE one.

I have had the same exact experience as Jeremy. I have my z-wave module removed too as it causes more issues than it does good. Hoping someone will figure out how to get this connected via local lan. It appears to be very low in the ST priority list.

@chevyman142000 I couldn’t agree more Jeff and the lack of support has rendered this thermostat worthless as it pertains to ST integration.

i wonder if this same process to get nest (wifi) communicating with st can also work with 3m50? anyone else look into that process and follow same for 3m50?

Each manufacturer has their own commands to communicate with their hardware. However, in another forum post there is a link that provides the manual with all of the http commands. Others have indicated it would be easy to do it just requires someone who knows what they’re doing to take the time to integrate it with the wifi module. I would open a ticket with support@SmartThings.com like I did so they know that there are those of us out there waiting for this functionality and our thermostats are completely useless at this point.

i do have andrew urman looking into it. i allowed him to look in my st account and even provided the user & pw to my radio thermostat web access. fingers crossed

I know he is a busy guy…has he had any time to look at this?

it works. thank you andrew for your advice. not sure exactly how other to fix others issues other than press confirgure on st within the things section once installed.
if you are still having trouble then try these instructions

  1. install usnap module.

or if already installed

  1. on 3m-50. unprovision the zwave module. select menu. select link/mate. select r1 or 2 depending which side you have installed. select link/mate

  2. remove thermostat from things

and or if not installed

  1. select plus on things to search for new device.

  2. if you are having trouble pairing then u may need to choose the settings icon on st to enter exclusion mode and select link/mate again to remove from st. mine kept finding then searching…i think st had it connected before then kept thinking it was already connected when it wasnt.

  3. once connected wait until the st activity log says thermostat idle. then select configure for the thermostat on st.

  4. mine now reports temperature all the time. yes the tiles have a few bugs but thats because u have two items reporting/changing the temp…just give it time.

6 for example. change target temp on st. go to app for thermostat. see target be same as before but change. i think the zwave communicates as a second or so delay behind the thermostat.

let me know if u need any help. be happy to help

oh btw. if you change the target on st app then it will change on the thermostat. if you change the target on the thermostat then it will not change on the st app…maybe a longer delay it would but i tried refreshing st app too and nada

updated. it finally change after about 3 min

I have this silly crazy thermostat and I’ve been calling different numbers for TWO DAYS! I can’t get anyone to call me back! The fan will not go off and it’s making us miserable in my home! Not to mention the house feels damp in the daytime and sticky wet at night! WE WAKE UP IN A SWEAT! I JUST WANT TO PULL THIS STUPID THING OUT OF THE WALL! Can anyone enlighten me before I drive to lowes and purchase a dependable one?

I have the 3m-30 with a zwave USNAP module. What I understand is that it’s the same device as the 3m-50 except for the 50 having the wifi module included already. I’ve been trying unsuccessfully to operate it with ST. I’ve tried a user made device type, the standard ST ones, and only the standard device type worked for 1 min. I can’t change any settings on the thermostat using the ST app. The temp read outs and current settings don’t display properly either. I really wish ST would address this. Thermostat capability is the most recent device type I’ve tried and while it can’t change temps it seems to be shaking accurate settings and temp.

i have same and i want to post my findings. it is true the temp read outs are not consistent. BUT this works wonders! i have had no problem since i installed this app.

once installed you just poll the thermostat. i chose every 10 minutes. the signal remains constant. your welcome

nothing to do with ST but mine quits working if the AA batteries are low. do you have voltage on the C wire?