30 Aeotec devices always offline, other brands fine

I have 37 Aeotec Z-Wave devices, 3 Fibaro Z-Wave devices, and 6 Zigbee devices. 30 of the Aeotec devices are always offline. Sometimes I can still turn them on or off through the app, though they are slow and unreliable. This is a typical house and the devices are all close together.

Many times I’ve tried repairing the network and disconnecting power to the hub, but it never helps. It’s been like this for 2-3 months.

What could be the problem?

Here’s my Z-Wave topology map, collected using a Z-stick secondary controller:

Thanks for the map, @Paul_Dillon, unfortunately without context (like what each device is and how it routes) it doesn’t help - it just shows you have a bunch of devices that can’t talk to other devices.

My gut says you have a bunch of them trying to go through the same bad repeater. So do this. Go to the IDE (https://account.smartthings.com) Go to My Devices, Pick a half dozen to a dozen of the devices that are acting up. (This will take a bit of time to look at each manually, sorry) Select the device to see its details and then scroll down to Route. This will tell you what route the device is taking to speak to the hub. It will look something like this:

This Device (3A) ↔ Home Hub
if it’s speaking directly to the hub

This Device (17) ↔ Front Garage Door (14) ↔ Garage Lights (71) ↔ Home Hub
if it’s routing through another device

Let us know what you find. ESPECIALLY if you see them all talking to a common routing device, or a missing device

Thanks very much for the response @nathancu.

I went through all of the devices. I’d say about 80% are routing directly to the hub, which is fairly centrally located. A few have one intermediary, and a few have 2 intermediaries in their routes.

I found this route which is strange, because 05 and 0E talk directly to the hub, but are both in this route for 1A:

This Device (1A) ↔ Laundry Fan (05) ↔ Kitchen Lights (0E) ↔ SmartThings Hub

I had a problem with the Z-Stick controller, and twice I removed it and re-added it. The old devices are still shown on the map. Neither the two old ones, nor the current one are shown in the IDE.

The map also shows 4 consecutive devices that are identified as “Repeater Slaves” in the Sigma Designs software, but are not listed in the IDE.

I can successfully send NOPs to the repeater slaves and the active Z-Stick device.

Nothing else strange looking. 30 of the 37 Aeotec devices are shown offline, and most of them talk directly to the hub.

Weird routes happen. I wouldn’t worry too much about it. :slight_smile:

Ok are you using Classic or new app - and if Classic, is Device Health on or off? Do you remember the results on your last ZWave repair? Did it come back clean or?

Oops I edited my previous post and added some info about repeater slaves after you replied.

I’m using both apps, but mostly the new app. Device health is on in the classic app. The last few Z-Wave repairs didn’t report any errors.

Turn off Device Health in Classic and see if they come back.

Done. Not sure how long I need to wait, but at a quick count it seems that one device might have come back online.

1 Like

It may just be a polling thing. AFAIK - Device health relies on getting status back on the devices in a timely manner - but what DH THINKS is a timely manner - not the device. It may just be a simple as not hearing from the device in the timeframe it thinks it should.

What are the models of the quirky devices and what DTHs are you using for them?

They’re mostly Aeotec Nano Dimmers, and a few Aeotec Nano Dual Switches. I added them using the new app, and left it at the default DTH. “Z-Wave Metering Dimmer” and “Z-Wave Multi Metering Switch” and “Child Metering Switch”.

I noticed that in the classic app, it doesn’t report anything as offline. I can turn the lights on and off instantly, thought it displays the wrong brightness level. In the new app, if I go into the device I can turn it on, but can’t turn it off.

Found the problem, but not the cause. In the IDE I compared the event list of a working device vs a non-working device, and found that the I could see COMMAND messages going out but no DEVICE messages coming back.

I flipped the house light circuits and it’s all working now (although Aeotec dimmers lost their dimming rate setting).

No idea what I originally did to get the devices to stop responding, I can only guess I sent the wrong commands at some stage.

I also noticed that a whole bunch of devices start chatting away all at once, periodically. Haven’t figured out what that is or how to configure it yet…

Much thanks for your help @nathancu.

Problem has returned. :frowning:

My Aeotec dimmers and switches are going offline one by one. 5 hours after flipping the power 22 of 37 devices are now offline.

In the IDE event list for each device, there is a message from DEVICE saying that it is offline:

I couldn’t find a Z-Wave command that sounds like a device announcing that it is offline. Is this really a message from the device, or is it just smartthings giving up on the device?

I suspect it’s the system claiming the device is offline - but unfortunately I think you’re going to need some extra horsepower who knows the Aeotec multichannel devices…

@Kianoosh_Karami - Paul is having some issues with a set of specific Aeotec devices that stop responding and needs some extra assist. Don’t know if it’s 30.x related - Suggestions?

Have you found any resolution to this issue? I’m having the same issue with 2 of my devices. Both aeotec nano dual switch with monitoring. Switch one works on both devices, but the second switch on both devices show off line in the new app and will not work with Alexa. Although, they work and show online with the classic app. Switch 2 on both devices is listed as a child metering switch.

This is a different problem than the one discussed in this thread. In the one discussed in this thread, the parent is also not working.

Multi channel Z wave devices require some changes to the DTH or the child device is not usable in the new V3 even though it was usable in the classic app. The DTH has to be updated to work with the new app. (You can find this problem discussed in threads for many different brands and devices, but they are all multichannel zwave devices where the parent is usable and the child is not.)

What DTH are you using?

Ok, thanks for the reply. I’m using erocm123: Metering Switch Child Device. Its now showing up as being able to turn on or off with the new Smartthings app, but still doesn’t show up for available devices in Alexa or Google home. Only switch one shows up which has a DTH of Z-wave Multi Metering Switch. In the new app, the 2 nd switch is always stuck showing “Checking status…”

Try asking your question in the following thread. I know Eric has updated most of his DTHs for the new app, but maybe he missed that one.

Common Composite (Child) Device Handlers

Ok will do. Thank you

1 Like

Hey @Paul_Dillon, did you ever find the cause of the problem or a solution?

I don’t have as many devices as you, but my Z-wave Devices have been rock-solid (on a SmartThings Gen2 hub) for 3 years… Until I added some Aeotec Door/Window Sensor 7 Pro’s to the system a few weeks ago.

The Sensor 7’s randomly go “offline” and now my Schlage Deadbolt Lock BE469ZP has gone offline frequently.

If I activate either (by moving the magnet sensor or punching in a door lock code), they do go back online in SmartThings.

Just seems odd that it started with the addition of Aeotec devices.

I’ve done all the basic troubleshooting: rebooting hub; power-cycling hub; z-wave repair; etc.