2018 - Current: Custom Graber Virtual Cord Z-wave+ Shades & Bali Autoview Z-wave+ Shades

The promised update is unfortunately delayed by a couple of weeks. Unfortunate last min delays, that said we are expecting new product launches soon; made for zebrablinds.com and zebrablinds.ca fully supported by us.

1 Like

I need some help with my shade. After replacing the batteries, it got completely disconnected - from both the remote and ST. So I went through the forget device /Remove from Z-Wave network procedure for the remote. For the shade, I had to choose the option to force the removal since ST app could not find/remove it. After that, I added both the shade and the remote control back to ST following the instructions posted here and in the website. However, when I went to the website in order to change the device type to Dimmer, I got stuck. For some reason, the shade was added as a placeholder with no Network ID. And I can’t change it to dimmer switch without one. How do I fix this?

The shade was most likely added using an Edge driver instead of the old DTH. You’ll want to go to the shade in the app and see what driver it uses. Mine was added as a z-wave switch and was able to change it to z-wave window treatment.

Thanks. The ST phone app doesn’t show anything about the driver used. I can’t even click on it and see the details as I can on my other devices. Only a long press work, and when I choose Edit I only see basic info such as rename the label.

Looking at the website (where you can define the type), it shows as "placeholder . I see all options in the dropdown menu (z-wave window treatment and the old dimmer switch that I always used), but I can’t change because of the missing Network ID Any idea how to fix that?

The “placeholder” label in the website means that device is using a driver. You can’t do anything with it through the website anymore. Can you try another exclude from the network, factory reset on the shade (hold down the button for 7 seconds) and re-add?

This post will help you understand whats going on…

1 Like

@neod192 I excluded/added again, but got stuck with the same issue. @nathancu , that looks like the reason for the behavior I am seen. However, this poses a big problem for Zebra Blinds because all their instructions require the device to be manually changed to a dimmer switch, so Google Home can find and control it.
I would not have bought their product if there were no Google Home integration, and I believe many others will be in the same boat. @ZebraBlinds any updates on how to integrate your smartthings shades with Google home given the new Edge driver approach?

It IS the reason - guaranteed. Im sorry that has that affect for you but respectfully, this isnt something for Zebra to fix… Somfy MAYBE - if they want to write a custom driver but this is not unique to them - it should be impacting any zwave blind using the driver. Using the Z-wave Dimmer DTH was only a workaround for strange behavior on the GH side.

I’d open a case with SmartThings about how the ‘default zwave shade’ does not expose things to Google to let them work correctly. (That’s your real issue)

1 Like

Changing the device type to dimmer is no longer required with the Edge driver. Make sure it’s set to “z-wave window treatment” from the ST Beta channel and Google Home will recognize it as a “blinds” device, which allows it to fully or partially open/close them.

3 Likes

Great! that worked. In case someone else get stuck in the future with the same problem - here are the steps I had to take:

  1. Follow this link to join the ST Edge Beta channel
  2. Click on Available Drives and choose the “Z-Wave Window Treatment” option. This driver will be installed on your hub.
  3. Remove the Zebra Blinds shade from your hub (Z-Wave removal device steps)
  4. Add the Blinds again to your hub.

Now the new driver will be used, and as described by @neod192 , Google will find it directly - no need to change from shades to dimmer switches any longer.

@ZebraBlinds , you may want to update the instructions in the main website.
@nathancu - not important any more, but I disagree with you. It’s the same as if you buy a Ford, find out that the tires are damaged and Ford tells you to go figure it out with Michelin…

2 Likes

The problem is in this case ‘Ford’ is SmartThings. They changed the interface. Graber /Somfy /ZebraBlinds whatever manufacturer is like AC Delco. If Ford updates an ECUbthat invalidated the spark plug gap, then it’s Ford to help you fix it. Not AC Delco.

1 Like

Is anyone bringing these devices into Home Assistant via Smarthings integration? I encountered an issue where I am no longer able to set the position on these shades within home assistant. I’ve reached out to their community forum as well but since the devices are coming from Smartthings I thought I’d reach out and see if anyone else has come across this issue.

Edit: So looks like other users are running into the same issue:

I checked the driver type in my shades and it is “Z-Wave Window Treatment” which seems to be the new Edge driver. Is there any way to roll it back to the old DTH and is that advisable to deal with this issue until there is a fix for this in Home Assistant?

I don’t think roll back is possible since the old one was in Groovy. The new one is the edge driver.

This was finally fixed in HA 2023.7.3. It was caused by SmartThings changing the capability type they were using in a breaking way.

2 Likes

Is anyone able to help me update the firmware? I tried to contact ZebraBlinds but it looks like their website doesn’t exist anymore.

Unfortunately appears to be the case.

If it is an install issue, put what issue you’re having here. Someone will try to help.

But for the files themselves - you’ll need to contact the location you bought them. Unfortunately bali/Graber/springs don’t make the firmware available online for general consumption and are only available through your vendor.

I am also looking for the 11.3 firmware. I would appreciate it if I could get the file. I also found the ZebraBlinds website is offline and their phone number goes to a failed call recording.

I have the 11.3 firmware now.

I know the website doesn’t work and the phone goes to a phone system error message and they have not posted anything on Facebook since 2021