2 Zigbee keypads regularly going non-functional

It’s good to check for the interference, but again, interference isn’t going to cause the keypad itself not to beep. :thinking:

Agreed. :sunglasses:

Generally, anything -60 and above ( meaning -50, -40, etc.) would be considered a very strong signal. -75 is usually OK for zigbee home automation transmissions.

Anything at -80 and below ( meaning -85, -90, etc.) is mostly noise and you risk losing messages,

That said… It’s a little more complicated for these specific devices because they’re battery operated. If they go to sleep, the signal strength is usually reduced. So it depends on where you hit them during the sleep cycle.

I don’t know what scale smartthings uses to report at LQI. If it’s the 0 to 255 scale, then those LQI values are terrible. :disappointed_relieved:

If it’s a 0 to 100 scale, then they’re not good, but maybe not horrible, since message transmission failures are about 10% .

Do you know or can you find out how LQI is reported in the IDE?

i have several of the zigbee keypads and a bunch of the ring zwave keypads, both using @RBoy dths. plugin outlet router/repeaters help. let me tell you the zwave ring keypad work oh so much better. just remember to pair it using S2 QR pairing.

1 Like

The simplest way to test would be to move the keypad close to the hub and then try it. If it starts working fine when it’s a mesh signal issue. Adding a few more repeaters should do the trick. We’ve found the Peanut ZigBee outlet to be an excellent repeater for ZigBee keypads. These keypads have a mounting backplate so it should be easy to remove them and move them around (it’ll trigger a tamper alarm but you can ignore it)

1 Like

I can’t guarantee that the keypad doesn’t beep due to the “fog of war”, and that the problem happens only every couple of weeks and only at a bad time makes gathering hard data difficult. I would be interested in knowing what that beep really means. The device has a “lockCodes” attribute and data which makes me think it does not need any outside resources to verify a good code. So maybe the beep means “I’ve told the hub the code is good.” Hard to know.

1 Like

There are three types of beeps. One is when press any button on the keypad (most keypads don’t beep for this but instead just light up to show activity on the buttons).
The most common beep is when it communicates successfully with the hub. So if you find the keypad lights up but there’s no action from SmartThings and the keypad doesn’t beep it means the mesh has an issue, i.e. the message isn’t reaching the hub or the hub response isn’t reaching the keypad.
With this keypad model, if the keypad “loses” it’s connectivity with the mesh, then you’ll find the top row 3 arming buttons start flashing serially. If they don’t flash serially but there’s no beep that means it’s connected to the mesh but somewhere along the route the packets are being lost (in either direction). If rebooting the hub resolves the issue it may point to an issue with the hub or some repeater close to the hub.

You could try to rebuild the zigbee mesh as explained here: FAQ: How to remove ghost devices from your z-wave and zigbee networks

2 Likes

Is the LQI measured node to node?

This is what I see:

Street Keypad

  • Last Hop LQI: 80
  • Last Hop RSSI: -80
  • Received Messages From Device: 24
  • Received Messages From Device (Duplicates): 4
  • Messages Transmitted to Device: 21
  • Messages Transmitted to Device (Failures): 2
  • Updated Time: 2021-06-04 1:13 PM EDT

Tradfri 6 feet from keypad and through 2 glass panes plus vinyl flooring and plywood sub-floor

  • Last Hop LQI: 76
  • Last Hop RSSI: -81
  • Received Messages From Device: 23
  • Received Messages From Device (Duplicates): 1
  • Messages Transmitted to Device: 17
  • Messages Transmitted to Device (Failures): 0
  • Updated Time: 2021-06-04 1:13 PM EDT

Tradfri 20 ft away, open air

  • Last Hop LQI: 76
  • Last Hop RSSI: -81
  • Received Messages From Device: 20
  • Received Messages From Device (Duplicates): 0
  • Messages Transmitted to Device: 16
  • Messages Transmitted to Device (Failures): 0
  • Updated Time: 2021-06-04 1:13 PM EDT

Tradfri 20 ft away, open air

  • Last Hop LQI: 68
  • Last Hop RSSI: -83
  • Received Messages From Device: 23
  • Received Messages From Device (Duplicates): 1
  • Messages Transmitted to Device: 19
  • Messages Transmitted to Device (Failures): 0
  • Updated Time: 2021-06-04 1:13 PM EDT

The hub is then 30 ft or so away on the second floor.

While collecting LQI information above I noticed that although device 644D is in the route chain, it is not listed as " * zigbeeNodeType: ROUTER" like the others are. Problem?

Hub is on channel 20. I can’t find a way to set the channel band on my Ruckus Unleashed setup. i believe it is “helpfully” changing the band on its own. Now to look for a wifi analyzer for mac.

So I figured out how to set the available channel bands on the Ruckus Unleashed, you have to set up a group. Channel 1 is being used by my neighbors so I isolated my wifi to the middle band and left the upper band for Zigbee. The Metageek site says that zigbee channel 26 should be relatively unaffected by Wifi but many Zigbee devices do not support it. It would increase my flexibility if I could use it but how to I know?

Update: 26 is not available. 25 it is!

1 Like

All my Tradfri are now 55 or better, and my keypads are 72 and 76.

Thanks everyone for the help!

3 Likes

LQI scale should be up to 250. This device is very close to the hub.

250 (FA), not 255 (FF) ? Never seen that one before, but it’s always possible. :thinking:

1 Like

Sorry, I meant 255

That device is 50 cm from the hub

this other one is 7 m from the hub

1 Like

I have 12 zwave devices and I don’t really have any problems with them. I can trigger the Mimolites from the phone for testing when the keypads are not functioning. They do not lock up after network rebuilds or reboots.

A disconnected device came back online after shifting the wifi channels I waited through the weekend to let things settle down but the raw device numbers do not look much better, especially on a 255 scale. I’m not sure what to make of all the devices having identical numbers now but at least I’m not having issues right now.

Street Keypad
Before

  • Last Hop LQI: 80
  • Last Hop RSSI: -80
    After
  • Last Hop LQI: 84
  • Last Hop RSSI: -79

Tradfri 6 feet from keypad and through 2 glass panes plus vinyl flooring and plywood sub-floor
Before

  • Last Hop LQI: 76
  • Last Hop RSSI: -81
    After
  • Last Hop LQI: 84
  • Last Hop RSSI: -79

Tradfri 20 ft away, open air
Before

  • Last Hop LQI: 76
  • Last Hop RSSI: -81
    After
  • Last Hop LQI: 84
  • Last Hop RSSI: -79

Tradfri 20 ft away, open air
Before

  • Last Hop LQI: 68
  • Last Hop RSSI: -83
    After
  • Last Hop LQI: 84
  • Last Hop RSSI: -79

The hub is then 30 ft or so away on the second floor.

Looks like you need an additional repeater to get signal up to the second floor.

Are there any particular architectural issues that might be blocking vertical spread? Tiled floors or ceilings, radiant heat in the floors, frequently operating ceiling fans?

Tradfri lightbulbs are good Zigbee repeaters for a SmartThings setup. You could try adding one in a ceiling fixture or hanging lamp with a Tradfri smartplug in the room above but about 2 to 3 m off to the side and see if that helps.

(If you use a hanging lantern, preferably one of wood or paper, otherwise not too much metal and definitely not colored glass)

You’ll need to do a Zigbee heal after adding those devices. Just take the hub off power for about 20 minutes and then after it comes back on the network will rebuild itself. This can take a little while, so don’t check the numbers until the next day. But if that improves them, then it’s just a backbone issue and you can figure out where you want to put the permanent repeaters to cover the vertical space. :thinking:

(Another option would be to move the hub to the floor that has your Zigbee devices since zwave has a longer range.)

2 Likes

Thanks @JDRoberts. I have placed the devices as best as i can to go through unfinished flooring and open air. the last hop to the hub is through multiple layers of drywall but I’ve limited the distance to under 10 ft.

I actually have a Tradfri on the floor between the core and the hub but zigbee is choosing to bypass it even after a heal. If zigbee were to include this device, the hop distance would decrease from 30ft to about 15.The LQI is worse than the one on the floor below so I’ll have to track that device down and try to improve the signal. The backbone path has all 4’ tube lighting with outlets on the ceiling. That’s the expected destination when I track that device down.

1st floor Tradfri

  • Last Hop LQI: 64
  • Last Hop RSSI: -84

Basement Tradfri

  • Last Hop LQI: 84
  • Last Hop RSSI: -79

I moved the 1st floor Tradfri closer to the hub by about 15 ft and rebooted the hub last night for 30 minutes.

The 1st floor Tradfri now has the same stats as the Tradfri 20 ft below it (and through the plywood floor) but the mesh has not adjusted to include it in the path. It is physically located such that it should be useful for 2 branches but is not included in either route. How quickly should I expect the mesh to adjust?

1st floor Tradfri before

  • Last Hop LQI: 64
  • Last Hop RSSI: -84

1st floor Tradfri after

  • Last Hop LQI: 84
  • Last Hop RSSI: -79

24 hours after the zigbee heal and zigbee devices that are physically in worse locations have better LQI than the one I moved and the routes have not changed. @JDRoberts, any point in doing multiple heals or for longer times?
These devices all have the hub as the next route hop.

15ft to the hub through finished floor/ceiling

  • Last Hop LQI: 84
  • Last Hop RSSI: -79

vs

Basement core, 40 ft away from hub vertically through a finished floor and a second finished floor/ceiling

  • Last Hop LQI: 80
  • Last Hop RSSI: -80

vs

Basement rear, 40 ft away from hub diagonally and below the next subfloor

  • Last Hop LQI: 68
  • Last Hop RSSI: -83