Zwave devices dead? (Hub Memory Warning)

Recently my Zwave thermostat went offline and now I can’t see any Zwave thermostats in the officially supported list.
When I tried to connect as a general Zwave device the application shows

while I can can connect Zigbee and Lan devices .
Does it mean the support of the ZWave devices is gone with Groovy? Or it’s just my account having too many (more than 2) Zwave devices?

This memory message seems to only come up if you try to add by Brand or by QR code, so I would wager that you’re adding zigbee and LAN by scan nearby or some other method that avoids that message.

Either way… Your hub is probably not very healthy at the moment. How many drivers do you have running? How many devices? I assume it’s a V3?

2 Likes

about 30 drivers some of them there just in case like Zigbee Thing

including

16 │ af8f84b1-b445-45e5-9c4a-07294a9682ea │ Z-Wave Thermostat

about 75 devices, because of a lack of multicomponent support ~5 devices are just a mirror of sub-components.

when I try to add Ikea motion sensor by brand it works.

That’s odd. Right now I’m at the memory warning level (not the hard stop where you are), and I get the same message trying to add a GE Z-Wave Switch by brand as doing the Ikea Motion. Not sure what to make of that, unless you already have the stock driver for the Ikea Motion running and the hub knows it can handle another device on that driver.

My understanding is that those memory warnings are RAM, not storage, so what matters is the running drivers and not so much any that aren’t in use by any devices. Below is a quick summary of what I’ve found on my own hub regarding the memory issues. If you have 20+ drivers in use then if you watch logcat on all drivers I think you’ll see a driver restart every minute as the hub tries to stay under the memory cap for drivers.

1 Like

Ok, that is even weirder than before.
I was able to connect ZWave thermostat via Android phone. Yes, my iOS still reports memory issues.

But it got connected to the DTH, no way to switch to Edge. and even though it’s connected I still can’t control the device, all the capabilities are not initialized… most likely it will get offline tomorrow.

the message in the log

1:12:33 AM: error java.lang.NullPointerException @line 494 (updateSetpoints)

Definitely weird. I see no difference in the memory warning between zigbee/z-wave and Android/iOS. If you haven’t already done so, a hub reboot is probably in order.

I definitely suggest watching logcat wide open to see if you’re getting driver restarts. I think you’re in the danger zone with RAM usage. It could be that that caused the thermostat to fail to find the edge driver.

And now I can not remove this device to pair it vith the code . Even force remove fails . the device itself shows “Err”