Zooz ZEN21 won't pair/add as switch?

I’ve read a few other threads about various other pairing ‘issues’ with the Zooz switch, but I didn’t see this specific aspect addressed. I’ve excluded/added this device several times, but the only way I can pair it is as a “relay.” I’m using this to just on/off some exterior lighting, and so far it seems to work fine as a simple off/on switch. But as “relay,” I can’t just the icon…mostly a quibble but still… More seriously, I suspect that I might run into issues if I wanted to include this device in a SmartApp/routine…but maybe not.

In any case, if anyone has any ideas on how to get this switch added as a switch, please share.


There’s an easy fix to this, you may just have to change the device type manually:

  1. Log in here with the same information you use for your SmartThings app: https://consigliere-regional.api.smartthings.com/

  2. Click on My Devices in the top menu

  3. Click on the Zooz switch

  4. Scroll down to the bottom and click on the Edit button

  5. Go to Type and select Z-Wave Switch from the drop-down menu

  6. Click the Update button on the bottom of the page

That should do it. If you’re still seeing the old icon, you can easily change it by clicking on the gear icon in the top right corner.


Thanks so much for setting me straight on this…worked like a charm. Many thanks!

1 Like