Zigbee Sinope - Newbie Questions - Wrong Time / Outside Temperature


Appreciate the quick follow-up response Sinope!

All makes sense.

Thanks again, and very pleased with the purchase. They look/function great!!


Hi, hoping you (Sinope) get an alert for this thread. Thought it might be best for the community to stick to the same thread (even though I know it’s getting a bit long in the tooth).

I noticed that the timezone didn’t adjust for the switch away from daylight savings time today, and I can’t figure out how to manually adjust it.

Any tips/hints?

I’m running SVN-431 for the API, just FYI.



Hi BGrudgingLee,
We’re currently working on it and we will provide the solution for SmartThings as soon as we have it.
Thank you,


Hi BGrudgingLee,
Here is the new driver that should allow the time to display correctly in SmartThings: https://www.sinopetech.com/wp-content/uploads/2018/11/Sinope-Technologies-TH1123ZB_TH1124ZB-V.1.0.1-SVN-435.txt

Thank you for your patience, and have a great day :slight_smile:


That did the trick! Thanks!!


Hey Sinope, one more question for you. It’s not a big deal, but I noticed that one of the thermostat’s doesn’t show the time any more (at the top of the screen on the thermostat itself). I disconnected it from WIFI and then reconnected it and it appeared, but it’s disappeared again. Any ideas? It’s still showing the WIFI connection is active, and I can control it, but just curious why no time is displayed on that one thermostat alone?


Time is sent to the thermostat every 15mins. Without disconnecting it from WIFI and then reconnecting it, can you only try to press the refresh button directly in the thermostat (things) menu?
When the thermostat is booting, it may take some time to get data from the SmartThings Hub. Maybe this problem is related to the thermal protection on your baseboard.

Best regards,


Thanks! That did the trick.

I’ll keep an eye on it for anything weird re: possible thermal protection on the baseboards.


Hi, something is definitely wrong. I’ve seen the thermostat power off completely and reboot, which I guess it’s been doing and why I’ve been seeing no time on the display (as it hasn’t yet pulled it post-reboot)?

We had the baseboard heaters installed new by an electrician. Is there any chance it’s the thermostat itself rather than the heaters? If so, then before calling the electricians, I could try swapping the offending thermostat for another in our house that I know is working.



Hi BGrudgingLee,
If the device screen goes blank and reboot, this could indicate that it doesn’t have proper power access from a thermal protection activation or a device internal problem. First, verify is something (furniture, curtain, etc.) blocking partially or completely the way. This could create a heat build-up inside your heating device and can trigger its thermal protection. Furthermore, mostly all electric baseboard do not distribute heat effectively if they are not backed correctly on the wall. In some case, depending on the size of the room and the power of your heating system, some huge gap between the requested setpoint and the outside temperature can make your heating device overheat and trigging the thermal protection. If the problem last, swap the faulty device with another working device. If the problem stays local, your heating system is the cause. If swapping devices resolve the problem, please reach back to us.

Please note that after a reboot, receiving info from the Smartthings hub can take several minutes.


I don’t get time at all on the thermostats.
I am using the latest 435.


Hi Thermoguy,

Please verify that you have entered your Zip code or postal code in your thermostat parameters and please verify that your hub has a good localization (within the SmartThings App).


So I need to edit the Device Handler ?


No, these options are directly inside the thermostat parameters on SmartThings and directly inside the hub parameter (for the localization).

(Akash Rathi) #35

hi @CharlieSinope, @Sinope_Technologies

I bought the Sinope thermostat to control my Fan Forced heater in one of my bedroom and used the latest Device Handler (SVN-435). Everything works great on the Smartthings app. However, the Google Home connection is broken. I am able to increase or decrease temperature by saying “Hey Google, set temperature to 70” etc.

The problem is that I am not able to turn on or off the thermostat! When I say “Hey Google, turn on thermostat/ heater”, the response I get is “that mode isn’t available”.
When I say “Hey Google set thermostat to heat”, Google Home responds saying “Setting the thermostat to Heat” but the thermostat isn’t turned ON somehow. Same thing when I ask Google to turn off the thermostat. Is there something I am missing here?


Hi Akash,
Thank you for your question!
Actually, you cannot «turn on or off» the thermostat when using our devices with SmartThings. However, you can ask Google Home 1) what is the actual setpoint; 2) what is the room temperature, and 3) to set the temperature at a specific setpoint.

For the thermostat to heat more, you can ask for a temperature above the actual setpoint instead of asking thermostat to heat or to turn on.

We hope this information helps you. Let us know if you have any other questions!

Thank you


Thanks for the tips.

Okay, getting back to this as I want to try and get rid of the portable heaters I’ve been using once and for all.

Is there a way to monitor when the thermostat is resetting? Maybe through WebCore?

I know a SmartThings question, but just wondering if there’s either a way to get an alert when the thermostat resets or if I can monitor it after that fact via a log file?



Hi there!
A solution may be possible if you look in the automation section of the SmartThings Classic App.
In the Smartapp / Climate Control, you can find some way to set up an alarm when the temperature becomes too cold.
This should be an easy way to get notified.