Zigbee Keypads Partially Stopped Working as of May 7, 2019

They may be doing that, but it appears they were simply doing more and better editing on some data fields for createEvent, sendEvent, and possibly other commands. The main downside is they did not tell this to anyone, nor did they bother to throw an error when bad data was found, it’s much easier to simply ignore the command. Idiots!

My system is now functioning as it was before this all began. However, that’s only until I complete porting a few more devices, mainly keypads, to Hubitat.

1 Like

Arn: could you please explain how to find, install and publish those two modules. Thanks for the help.

The linked release notice has the information you need. Should you not be using the IDE’s github facility, the release notice includes links to the raw files for manual update

1 Like

We’ve disabled the change that caused the Keypads to stop working and will investigate better error handling options to prevent it from happening again. That being said it would be a good idea to update to the latest code that @arnb posted.


Arn: I have updated the device handler for the keypad via the raw files for manual update that you provided, but my IRIS keypad V2 is still not working properly. I do not use SHM Delay APP because I do not use the delay function when arming / disarming using the keypad. There is no need to have delay as my keypad is in the garage. I only use the device handler and ethrayer’s Lock Manager for User PIN.

I tried, deleting the Keypad from the Smart App and re-pairing the keypad, as well. I also deleted the original Mitchpond Device Handler and added the updated file for the keypad device handler, too. I am not sure what I am doing wrong. I have no trouble arming / disarming using the Smarthing APP on my phone but the keypad is to no avail.

This is the link file that I used for the keypad device handler:


Can you please provide some guidance? Thank you!

  1. Provide warning to the community a few weeks in advance of the change.
  2. Modify the Save, compile phase to throw an error when the data appears wrong
  3. Throw an error when an error is caught, rather that tossing the command into the ozone

Regarding the code reversion: Perhaps it will help some, and confuse others, who knows. Those of us who were severely impacted have moved on.

The updated DTH is not compatable with ethayer’s Lock Manager, or an any version of SHM Delay before v2.2.9. Either move on to use the SHM Delay or reinstall Mitch Pond’s DTH.


1 Like

Hi ,

I’m facing same issue. The keypad just doesnt respond to codes. I reinstalled Mitch Pond’s DTH, but still nothing. Nothing happens when you key in any code Any help ?


This issue was resolved a long time ago. The original mitch dth is no longer used by any apps and doesn’t have the necessary patches to keep it up to date with the platform changes.

Make sure you’re using the latest version of the Enhanced Zigbee Keypad DTH or which ever app/DTH you’re using (if they have a specific DTH for that app).

What keypad are you using?

I’m using Iris V2 keypad on US hub and smarthings classic. I was using Mitch’s DTH. I dont have a need for delayed locking. Any step by step on how to switch DTH ?

What are you trying to do? What’s your goal for the keypad?
Installing or updating the DTH is easy. Step by step instructions here which cannot be allied to any DTH. Generally it’s better to exclude and re pair the device after updating to a different DTH due to changes in ways DTH initialize devices.

Below is a link to a modified version, by @arnb, of the Mitch Pond DTH to work after the platform changes. It may or may not solve your issue but it’s worth a shot since you were using the original DTH. I hope it works for you!


Hi thx for yory reply. the link is not working . Any updated link ?

Hi , basically run hello home actions (eg goodbye to lock SHM and welcome back to unlock SHM) after successfully inputting the right code. the device is outside home, thus no need for the delayed actions

You have a couple of options, it looks like you’re using SHM Delay, try starting over from scratch and see if that helps.

If you don’t need the entry delay features then you can use a simpler approach if you have access to RBoy Apps. Install the Enhanced ZigBee Keypad device handler and install LUM SmartApp to program codes on your keypad and create actions when the codes are used, for example run the hello home routines, change Classic SHM state. You can create specific actions for each action button on the keypad (on, partial, away, night etc) and create separate actions for each code or global actions for all codes. The enhanced zigbee DTH also works with SHM Delay so you can switch between Delay and LUM in future if you choose.

It’s best practice to keep only one device handler, so whatever approach you choose delete any used DTH’s to avoid problems later on due to a stale DTH issue on the platform.

Give me a bit. Arn has been updating things to work with the new app so some fits may be offline. I’ll look in the repo and see if I can’t find another link for you.

I would hold off starting over, if using SHM Delay, until trying the new DTH.


Complete documentation for SHM Delay is at
[Release] SHM Delay Version 2.0

1 Like

Thanks arnb !
I removed and added the device again, used the original Mitch Pond DTH. To a certain extent it worked (it now executes routines correctly. updates temprature ,strange thing is that motion sensor in the app is always on, even if no motion but not a big deal)

I tried the new DTH with your updates and functionality but unfortunately it didn’t work. I think because I’m using the original SHM smartapp , right? I’m not in real need for the delay functionality.

The current DTH must be used with the current SHM Delay. ST changed silently changed data format requirements a while back. Please update to the current levels and you may have a happy holiday.

Thanks arnb ! I updated both the DTH and the SHM Delay smartapp using yours and they now work perfectly!! Amazing work! Happy Holidays !!!