Zigbee - from flakey to stable

Phil, for reference that is the kit that I’ve purchased in the UK from Farnell/mouser as I couldn’t find the XBee modules particularly cheaply and the issues that everyone has mentioned around the USB adapters being hit and miss so thought this was a reasonable way of getting a working device.

Just got the first one loaded with the ZIGBEE TH Reg firmware opposed to the 802.15.4 that they come with and programmed with the settings as pulled together from the thread in @gswoosh’s post #175, it’s paired successfully with Smartthings and mapped my ZigBee network.

Now to get it in a suitable case to put out between the SmartThings hub and the garage where I’m trying to use some of the Xiaomi Vibration/Motion Sensors.

Did anyone get a DH working with the XBee’s?

Thanks to OP and everyone that’s contributed to this!

If your using Xiaomi devices, you might be interested in this thread.

I have unplugged my Xbee’s since aquiring two of these devices.


Thanks Don, I am but the XBee I’ve configured is doing the job of keeping the sensors out in the garage connected up.

Out of interest why have you moved from the XBee to the other device for ZigBee repeating/router?

@Bahubali @xamindar

I’ve found the same model XBee’s that @adam_walker was using at the beginning of the thread here, got two for £7 as the power output is higher on the Pro’s: https://www.ebay.co.uk/itm/DIGI-INTERNATIONAL-ZIGBEE-MODULE-XBEE-PRO-ZB-PCB-ANT-XBP24-Z7PIT-001/173543583604?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

However I’ve not been able to get the XBP24-BZ7 to play with the SmartThings Zigbee network unlike the newer ones I started with. @adam_walker any chance of getting a copy of your config file to try?

Scan of my network below, the Green Router is one of the ZBee S2C’s that came in the Digi Connectivity Kit, working a treat and keeping the Vibration Sensor in the garage connected. The XBP24-BZ7’s is the ? device connected to my laptop and running the scan from XCTU it’s showing as Type: Unknown but is configured with the same firmware that @adam_walker was running and the settings as per the thread above apart from AO as don’t have option 7 available only 0,1,2,3. It also isn’t found as a thing by SmartThings so there’s something not right somewhere, any pointers would be gratefully received.


I originally got one of the above mentioned sensors as a test. It works very good at what it is supposed to do.

I’d say the main reason it it’s a plug and play solution. I do like messing with the Xbee. This sensor just plugs in and does its magic.

Also it has other sensors on board to give you extra data. It tells you things like light levels, temperature, pressure. Makes them available to smartthings environment for use.
I like that it tells me the number of devices connected through it. Easy to see if my shed sensors are routing at a glance.

Since I’ve installed my environment sensor he has modified and created newer version with even more options.

Hope that helps.


I believe you can select AO = 3 it should be the same as 7 in some firmware versions. Your looking for this setting “Explicit+ZDO”

I am sure you have read these 2 threads but there is a bunch of information on Xbee and some of my own experiences with them to possibly help you.

I know when 1 was having issues getting smartthings to see my module it was a setting for " I think parameter D6" been a while since I have messed with these.

I have also had to load the default firmware and power cycle Xbee, Then load the firmware I wanted to use and reconfigure all the settings again to get it to connect again once it had before.

It can be a frustrating process.

Hope that helps you.

Thanks for the replies Don, yeah I’d read that AO=3 on these should be the same and had that set, strangely I’ve unplugged the one XBee Pro that I’d left powered on and connected back up to the laptop and it’s now showing happily as a Router, I’ll have more of a play around with it later this week.

Can’t argue with the other device’s extra features, particularly the visibility of it being alive and the number of devices routing through it. Might have to take a look at getting one of those to play around with also.

Take it no one got anywhere with a DH for the XBee then?

Several people sent me stuff to try but none of them really worked.

Hi. Really appreciate the compilation. Going to try it myself now as I have reached the limit of Zigbee devices and my Xiaomi sensors keep dropping off. I wonder how are your xbee router doing? Any issues you faced thus far?

The xbees work good unless they lose power. So having a battery backup is important.

Here is another option that is in the works.

The XBee’s are nice for routing and also to see the mapping of the network. But they can also be a bit complicated to get setup and more expensive. If you just want a repeater for the xiaomi devices the tradfri outlets are cheap and have been reported to be working really well with the xiaomi devices. And they also are an outlet that you can choose. Might be worth looking into those.

1 Like

Thanks for the advise… Was bit worried the tradfri bulbs not being stable and all. Will try them out before the xbee.

Please let me know what you find. I need some outlets but haven’t found any to play nice with my Xiaomi devices.

Let us know how the bulbs work out. Specifically I’ve only seen positive news about the tradfri outlets I mentioned but I haven’t seen anything specifically about the bulbs.

I recently bought a Tradfri Outlet, and after using my XBee to check that some of my Xiaomi / Aqara devices are routing through it, I can confirm that the outlet works great as a repeater with Xiaomi / Aqara devices.

1 Like

That’s great - any idea about how many children they support?

Not sure. The most I’ve seen is 5 so far.

I can say that while my Tradfri Outlet easily “grabs” the connections of Sengled bulbs, it is stubborn about picking up any of my Xiaomi / Aqara devices. I have to re-join (repair) them to force them to choose the outlet to connect through.

I joined a Xbee to my network. I want to try to remove it but I’m unable to. It is not showing as a device in the Smartthings app or in the IDE. I tried resetting the Xbee back to the default settings and then when I reconfigured the settings it was just picked up by Smartthings. I can see it’s connected to Smartthings when I do a network scan. Is there anyway to completely remove the Xbee? Thanks

What are you exactly trying to do - use the XBEE for something else besides Smartthings? Just trying to understand what your goal is.

Yes I was going to use for something else. I was able to reset it the defaults and reflash the firmware. After that it was finally removed. Thanks

1 Like