Z-Wave Smart Fan Control Custom Device Type

I would love for Echo to work with low/med/high commands. I have 8 fans, not going to set up 24 virtual switches and associated triggers.

1 Like

Take look at this…

Perfect! I can work with that. Thanks!

@ChadCK Thanks for the custom device. Just installed it and works great!

@ChadCK is there a way to have the physical switch to always reset to MED after its been turned off? This way a flick of the physical switch to ON will always start in MED?

You can do this with the Smart Lighting app. Set up a rule to Turn on and Set Level of “your fan” to 50% when “your fan” is switched on.

2 Likes

ahhh good call. Thanks for that.

Another question, how are people using switch on the physical side? Seems a little convoluted to hold the paddle up or down and wait for the setting to go higher or lower. Is there a way to make it where one toggle of the paddle sets to low, 2 sets to med and 3 sets to high or something like that?

There doesn’t appear to be any way to do that per the switch documentation and the advanced z-wave config stuff.

http://www.ezzwave.com/advanced-operation/

@ChadCK Thanks for this DTH. I’ve been using it for a couple of days and wonder/hope you are still developing it. Something I’m looking for (that may well be beyond the ability of the device) is for an isPhysical message to be sent if it’s pressed OFF when the switch is already OFF.

I get the isPhysical event if it’s on, but nothing when the switch’s pre-existing condition is already OFF. Any chance you could look at that?

Thanks for sharing this @ChadCK! I just used this on my Z-Wave Smart Fan Control, and it works exactly as I wanted to. The only modification I made was removing the slider as I didn’t need it.

I’m new to using the SmartThings IDE and Groove, so I’m pasting the changes I made in case there is a better way to remove the slider, or in case anyone else finds it useful:

Comment out (or remove) the following lines from the code:

		controlTile("levelSliderControl", "device.level", "slider", height: 2, width: 2, inactiveLabel: false) {
			state "level", action:"switch level.setLevel"
		}

Then, replace the following line (two lines below the above):
details(["switch", "lowSpeed", "medSpeed", "highSpeed", "indicator", "levelSliderControl", "refresh"])

With the following:
details(["switch", "lowSpeed", "medSpeed", "highSpeed", "indicator", "refresh"])

Again, thanks for sharing!

Installed a new GE fan control switch yesterday, having preloaded @ChadCK’s DTH. I was a little surprised when it didn’t pull that DTH after inclusion, using the stock dimmer instead. A quick fix in IDE had me straightened up, but wondering if I missed a step for auto-assignment?

BTW, DTH is working great, thanks for this!!

Just curious: Is there any way to get the fans to reverse direction? I installed the GE switch this afternoon on my Postino fan, which has a reverse setting on its remote. (Reverse had worked fine on my old standard switch.) Since installing the smart switch, the reverse setting doesn’t seem to work anymore, and I don’t see a reverse setting in either this custom device type profile or the stock app. Any help appreciated!

Reverse isn’t part of any device type, and it’s not a command supported by the zwave switch. I wish it did because I have a ceiling fan without a physical reverse switch on the motor, so it’s always going in one direction.

This is a long shot, see last post:

Use your ST mobile app instead of the remote?

I found this that should help which is similar to @johnconstantelo suggestion.

If you have a remote controlled ceiling fan with no reverse switch don’t worry if you lost the remote. You can reverse the direction of the fan manually. Remote controlled fans are controlled with a sequencing code from the remote which is simply controlled by cutting the power ON and OFF. To reverse your fan direction turn off the power switch to the fan. Take a broom and hold the blades still. Flick the power on and off a few times leaving the power off. Wait a few second then turn the fan blades in the direction you desire then turning the power back on to the fan. The fan should now continue in the direction of your choice.

If this works for you post back because you would think then this can be mimicked in the device handler or a smartapp for those lucky enough to have that style of ceiling fan.

Trying to install this device handler but not able to see the device types in update from Repo. I am entering Owner ChadCK, Name SmartThings, Branch Master but nothing is coming up. Is my info incorrect?

Not sure if it matters, but I have “master” (lower case m).

Thanks, I figured it out, I have my fan now with this device type. The Leviton quite fan control does not seem to be compatible with my Altura 68 inch fan from the home depot. If I select low the fan does not turn on, if I select med it turns on but seems like it is on low, and when I select high it stays the same speed as medium. I am going to try to the GE fan control and see if that works better.

I’ll have to use my SmartThings app (and Alexa), since the switch seems to have disabled the remote control (as well as disabling the light and the reverse function). Oh, well. I’d rather have voice command anyway.

Will do! Thanks for the ideas. I’ll have to wait a couple of days, though, as I’m in the middle of a renovation and can’t get near the middle of the room. :slight_smile:

I believe your Leviton switch is OK with the Altura. I wonder if the real issue may be that built-in internal Altura receiver speed controller is not set at full lighting and to HI speed with the wireless remote? I wonder if the remote control button was pressed accidentally switching the internal speed controller to Medium speed so that is as high a speed that the Leviton can achieve for you? This is same problem that people have with the older manual pull chain speed switch when they accidentally pulled the chain by accident putting the speed in a lower speed or the light OFF. I had to cut the pull chains so that my family quit doing that. The Z-Wave controller is only capable to controlling to whatever the fan controls were set to.

FYI; I love your fan choice! Looks great. I think the ideal future solution would be if the community could get the new Ceiling Fan controller to work with SmartThings so you could replace your [Altura receiver] (http://www.homedepot.com/p/Black-Replacement-Remote-and-Receiver-Set-for-Altura-Fans-082392052133/205489329) instead of installing the Leviton or GE Fan controllers.

If the above doesn’t work though simply try adjusting up the lo/med/hi preference values as stated in the original posting.