Z-Wave Smart Fan Control Custom Device Type

I changed the values on the device type to 32 & 66 and it does change the indicator on the switch to low, med, and high, but the fan only turns on when its on high. It has to be a problem with the switch not outputting enough power for my fan.

That is not necessarily true. When you added the Leviton controller you didn’t remove the existing wireless receiver that is inside the ceiling fan so the Leviton is limited in what it can do based on how you left your existing receiver set. Your problem sounds like it could be with your existing fan setting. So try this; put the Leviton smart switch on High speed to get the fan running then use the Altura remote control and set the fan speed to HIGH by pressing 3.

1 Like

Thanks, I changed the fan to high with the remote and now the fan is on high but it only turns on at 85% or higher. It seems the switch is not controlling the fan speed only turning it off and on. I ordered the GE quite fan control, should get it on Monday and going to see if that works better with this fan. I have these hampton bay altura 68 inch fans in 6 rooms so I need to get them automated.

Interesting. If the GE Smart Fan Controller doesn’t work I am pretty confident we can get your fan running properly if we remove the wireless controller that came installed at the factory if you want to do a little modification. I am really tempted to go buy that fan because I love that look and want to replace the ceiling fan that is 15 years old in my bedroom. If you don’t mind, what is your ceiling height? My ceilings are 8ft high and wondering if would work.

Have there been any updates with controlling the fan speed with Alexa?

On/Off seem to work. I can turn the fan on directly to medium, high or low. However, the problem comes when trying to adjust to medium. It doesn’t seem to recognize that command. I can say “set fan to low” or “set fan to high” if the fan is already on and it works fine. It is just the adjustment from high/low to the medium setting that doesn’t work.

Any ideas why or how to correct? Thanks.

Tell her to set level. Not low,med,high.

Alexa set living room fan to 50% (med)

Or something like that , I can’t remember if the word level needs to be in there or not.

Yup - everything works fine if you say percentages. I was trying to get the words working - as it is more intuitive for the other family members. Saying the command with “low” and “high” work just fine and “medium” if the fan itself is off; however, it is just the high/low to medium adjustment if the fan is on that doesn’t seem to work.

Is it something with the coding of the device handler?

Sorry, I misunderstood. I’ve never tried to tell her low,med,high. Didn’t even realize you could? Have to test next time I’m home.
Reading your last response has me even more puzzled. I’m going to have to see what mine does.

Hopefully someone will chime in with a good reason why?

GE Fan Control did the same thing, only works on Med and High. One of my 68 fans does not work and I think its the capacitor on the built in reciever. I was reading I can buy a capacitor and bypass the receiver but the wiring diagrams on the instructions I found are a little different.

You can use EchoSistant and use the following command

Low
Medium
High
Turn up
Turn down
Speed up
Slow down
Go faster
Go slower
Set to
Set level
Set
Adjust

Pretty much however you would say it… And if there is any other phrasing, let me know and I’ll put those in too

John, I was trying to use the below link, but appears to be dead, is there another one?

Yep, that’s a really old version. I thought I caught all those. Here’s an updated link:

https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-ge-fan-control-switch.src/my-ge-fan-control-switch.groovy

Thank you, much appreciated.

1 Like

Is there an easy way to make this work with Google Home “set the fan to 33%” is not as cool as “turn the fan on medium”. I was thinking I could make a few virtual switches and tie into IFTTT for each fan but would get messy and cluttered. Any ideas?

thanks

Any chance this is integrated with Github? I can’t seem to make the connection

Thanks
Rick

That link does work, but you can also get it from github integration:

Owner : constjs
Name : jcdevhandlers
Branch : master

I have the integration setup currently using Owner: constjs
Did you suffer from autocorrect, or should I update my settings?

Yes, stupid autocorrect!

Owner should be constjs.

@ChadCK Hey there. I’m interested in trying out this DTH, but I’m having a bit of trouble with Github integration. After I enter your info, nothing at all comes up when I use Update from Repo for your Github. I might be missing something.

@johnconstantelo I also tried your version of the DTH, but I found that the ST interface always reverted back to High regardless of what setting was selected. I feel like I saw that mentioned in the thread, but I couldn’t find the reference again. Any ideas?

I had this happen recently just on one fan. I manually adjusted the fan at the switch and eventually everything synced back up again. Only noticed it the one time.

Edit: It just occurred to me that I’m using Chad’s DTH so this issue may be more an issue of how the Thing (Fan Control) is reporting back to the handler. Or, as these two DTHs are based on each other (I think) I guess it’s still possible they have a common bug.

I’m interested in this too. I never got this one to work with any Github integration.