Z-wave repair showing ghost device

Thank you that worked. So now what if in the future I purchase a new z-wave device does that mean it will never be able to ger ID 14 again?

No, you’ll be fine. The way the SmartThings zwave controller works is that it issues a new device ID in sequence (so the newest device always has the highest ID) until it has reaches 232, the maximum number of devices on any zwave network. Then when you try to add the next device it will go back and use the lowest available device ID. So 14 will get reused eventually if you need it.

So z-wave will always be a number from 1-232?

Why do I see this then? (device ID 2B)

Its one of those Iris smart plugs with z-wave repeater.

Edit: Ahh i see its in hexadecimal

1 Like

I have something that I don’t know what to call it. But Ghost device is close.
Back story: I have a hard wired alarm system with door and window sensors and one, very good motion sensor. I purchased many boxes of GoControl kits (2 contacts and 1 motion). I decided to play with the idea of hard wiring the contacts into my alarm panel, one contact per zone. Well, it worked. Very well I might add. So I got cocky and added one to the motion zone. It too worked. But as you might guess, in SmartThings app, instead of showing “motion or no motion” it showed “open or closed”. Not a big deal but I thought I might try and fix it. I edited the device handler and changed every instance of open to motion and closed to no motion. I updated the handler and it worked. Except for one thing. In SHM, I have two instances of the motion sensor. 1 that reads open or closed, the other motion/no motion. This does not show as a device anywhere else but in the SHM under Right Now tab and it shows up on SmartTiles. It does not show in the IDE at all. Even in the log of the device it only shows one instance of the device as motion/no motion. Any Idea how to get this “Ghost” out of those two areas?

I would creat the same device name in IDE and see if you can then delete it. @JDRoberts would know better though.


Glad to hear the main project is working well!

The SHM issue doesn’t sound like what we would technically call a ghost device. A ghost is a device that did exist on the network, was forcibly deleted, but its ID still shows as active in the controller’s device table. Those are reported just with a device ID, no name, and shouldn’t show up with any attributes at all.

Since in This case it shows up with different attributes, then it most likely has to do with the device handler which has been selected. It sounds like it is being treated as a multi sensor which reports both motion and open/close.

(My guess is this has to do with the smart home monitor feature where it reports on “all sensors” of a particular type. )

It may even be correct to have it show up twice under SHM if it has both capabilities. My guess is that in editing it, you left in the original capability and that’s why it’s showing up twice.

Since you were trying to edit a device type handler, I suggest asking the question in the developer category on writing device types, and people there can look at your code and help you fix it. We’re getting pretty far off topic for this thread. :sunglasses:


By the way, you might want to take a look at Mike Maxwell’s very popular universal device type which is intended for exactly this kind of use case. You can use it to gracefully have an open/close contact sensor report instead as a motion sensor and all the other parts of SmartThings will work correctly.

1 Like

Thank you. That is very helpful. Especially the universal dh.

1 Like

I have 3 ghost devices that I can’t get rid of. I went and created a device using that name but when I try and delete using my android it won’t delete. I go through the deletion process, it gives me the option to force delete so I do but then it’s still there in things.

If I delete in the IDE, it shows up again as an unnamed device when I run Zwave repair. Support ticket opened.

I also deleted all my routines but they still ran until I went into the ide and deleted them

And, I was also unable to unpair devices from routines. I would remove them from the routine and they would be right back in the routine again next time it ran…that’s why I deleted all my routines.

What the heck is going on? System was working awesome after their supposed migration to their new database now it’s turned to complete crap again.

As an update, got these Ghosts deleted, performed Zwave repair and presto! System works better than it has ever worked. My “out of range” devices respond with 100% reliability at this time.

Only a couple failed light activations in the last month or so out of 100’s of routines. In other words, I have like 5 lights that turn on when I open a door and maybe twice, 1 of the lights has failed to turn on.

I’ll take it! Thank You Smartthings!

1 Like

I know this is an old thread. Asking here for exact the same problem. Any help would be appreciated.

I ran into the same problem. I have three orphaned nodes lingering and tried to delete them via IDE add -> App add -> manual delete from App but in vain. I’ve opened a support ticket and the support worked with their engineer for couple of days and propose me with a new hub. It’s nice for what they can do, but the solution is far from ideal. How did you manage to remove those orphaned nodes from your hub? Thanks so much in advance.

Support removed mine sometime ago. Then I got new ones and they said they can’t do it. Then they disappeared by themselves after last firmware update an reappeared one day later.Right now I’m just living with them.

If it’s zwave try and get the device ID of the ghost device then add a device in the ST IDE select a DH that’s zwave doesn’t matter what it is, though a guess at what the ghost device is, is what i do. Then put the ghost device ID. Save
Then using the st ide remove that device

I have more than 7 bad nodes in the beginning and the support was able to mitigate some of them, leaving 3 bad nodes behind right now. Every once in a while my hub (according to the log) would choke up with some of these nodes with [Error: 120] and started doing the power cycle, causing the whole network unresponsive. How would you able to live with them?


I was able to delete them from IDE, but that brought me to ground zero - I still have three bad nodes lingering and they cause a power cycle once in a while when the hub identifies them.

The thing is that they do not show in IDE for me. Only support can do it.

You should see the ghosts during the zwave repair then you use that information to do what I say above

Support was able to remove the devices for me.

Yeah I was able to add/delete those ghost devices, but eventually they were still lingering in the system. I contacted the support and they were unable to remove them either. They ended up sending me a new hub but I am really hoping not to go with that route.

So here’s what I’ve tried so far:

  1. Support wasn’t able to delete those 3 nodes for me.
  2. Add those devices with the z-wave ids via IDE, use app to discover them, and tried to delete them with app. Can’t remove devices with app, and it needs to be done via IDE.
  3. Tried to “replace” the devices via App as it was suggested in the forum long time ago. It failed at the health check.

Any suggestion?

You, me and many others are at god’s mercy. Support cannot remove mine either and their only suggestion was to reset hub and all devices and start fresh.