Z-Wave Popp Strike Lock Control POPE012501

Hi guys,

Has anyone experience to include such a Strike Lock Control?


Are they any readymade Device HandIers I can use?

My plan is to use this device within an existing intercom system, which
allows me to switch the button to open the door.

One problem migth be, that the button has to be closed for about 4- 6 seconds throught the relay on the POPE012501.


1 Like

Has anyone used one of these devices and found a device type which works? I think I can hear the relay switching with it set as just the standard z-wave device when I operate on/off, but the relay contacts don’t seem to close.

I have one of these - it works a little with the z-wave lock device handler. I use mine to ring an old door bell so use it as a remote switch (unlock with timeout)

I have only had it a couple of weeks and does work fine. I have updated the device handler to work as a push switch. The code is on Github user (johndoyle)

I find the device very unreliable. It keeps dropping offline i.e. showing as unavailable. That is despite a z-wave repeater 3 feet away…

Disappointing. I shall probably have to bin it.

I have this issue but this is just a reporting issue and not a disconnection problem. I ran mine for the development using a 12V DC power supply and then moved to a 9V Battery once I was happy it was working. After a factory re-set to make sure it was in Battery mode (LED does not flash every second) I do not get smartthings saying it’s offline. I know why but not yet sure how to solve. This is next weekends job :slight_smile:

I see the device report in Smartthings as “Unavailable” but this does not mean that it does not work. It still responds as expected. I think the “poll()” method has something to do with it but need more time to work this out.

Mine is running on mains power and does not respond to commands when it says it is unavailable.

I didn’t realise one could set it to battery or powered mode; how do I do that please? I assume it’s a parameter to set in which case I’ll set it to mains power and see whether it then stays connected.

You can set the state by using the device handler to set a parameter but the easiest way is to remove the device (exclude) from Smartthings then hold the button down for 10 seconds, you will see the LED do a special flash, and at this point it either sets it self in mains or battery mode. You maybe able to do this without the exclude part - did not try that.

To include again you have to either press the button momentarily or press it three times within a second. Three sets of instructions out there.

The best way to see what “mode” it’s in is the LED. if it’s off most of the time then it’s in Battery. If it’s flashing every second then it’s on mains.

If you have yours on Mains (not battery) then I am surprised that you are getting unavailable in smartthings. this only started to happen once I moved to Battery. Is this right? If so then what Device Handler are you using? It maybe that is the problem.

I am using a lock handler as the device type. Although it’s running on mains power, the light is not flashing regularly so it clearly thinks it’s in battery mode.

I was hoping there was a command I could send to get it to switch into mains mode. It probably polls more often in that mode and might stay online.

I found on setup the 3 press option was what made it ex/include by the way.

On the command front - yes there is a parameter to force to a mode (param 1) but you have to send that from the zwave controller and given that the device handler does not do that then you will need to change the DH to send that command.

That’s helpful; thank you.

I use the wonderful device type ztweak for one off changes to parameters: it lets the user read and set commands for any device, and then one switches back to the normal device handler once the commands have been installed.

The manual (link above) has a list of the Prams you can use. I was incorrect on the pram - it’s 5 - sorry

Hi I’m thinking about getting one of those. My door phone installation only requires me to bridge two wires to get the lock to open. It looks rather complex in the manual and I don’t see why? Would it work like in the second picture?

This is how I’d like to wire mine up, would that work?

Yes it would, just got my popp strike lock today and it works like in the pic above.
John’s device handler works great:

I’m posting this for anyone searching for a solution for communal door phone strike lock integration with smartthings. The model I’ve got is urmet 1130, if you wire it like on the attached picture you can remotely open the main door.

Throwing in some keywords for google:
door phone, entry phone, intercom, domofon, strike lock, momentary switch, gate lock, door intercom


Do you have enough space to get the lock control board and the battery into the intercom?
How does the battery monitor works?

I couldn’t get the battery monitor to work, so it’s just showing Batery: %
But the board and battery fit like a glove, take a look, mounted with some blue tac

Made some changes to John’s code, now with lock icons and event log:

Can someone help me? I want to connect popp strike to a little piston to lock and unlock my door.
I don’t know in which mode I set all.

What have you got? how does it look like? post some pictures.

I would only understand if I can add Popp Strike on Smartthings hub v2

I initially had trouble with my device dropping off-line and needing to remake the z-wave network every few minutes.

A week ago i modified the device’s properties to set the parameter 5 to mains mode rather than battery mode (and I power the device from the mains). It has not dropped offline since.

I was using the standard lock device handler though it isn’t very elegant. I use the device to open/shut a garage door so the status that is shows (locked/unlocked) is inaccurate and it’s every other use that it would be open (or shut). Now i need to try the new handler shown here and see whether I can pick up the open/closed status from the separate device which i use to register that and display that for the Popp instead!