Yale Z-Wave module 2 won't go in to learn mode

Hi I am new to the whole Smartthings integration and its fair to say that whilst I’m not a complete technophobe, I do seem to be struggling integrating a Yale Z-wave module.
I have a Yale Keyless Connected Smart lock with a Yale Z-Wave Module 2.

I had it integrated with a hub, however the hub had issues and has been replaced (v3 hub).
I have added the new hub to my account and thats recognised fine. However when I try to pair the zwave module it doesn’t seem to respond. The lock recognises that the module has been installed (as it goes to the menu allowing it to be put in to add/remove mode). However when I press 1 to put it in to learn mode I get the beep.,beep, beep,beep tone where I believe it means it isn’t accepting the command. I’ve tried to exclude/remove it and I get the same issue. I can’t do a local reset as the instructions say press 4# then 0# but the zero isn’t displayed.
I have the app in add mode and have tried adding both a Yale Z-wave and a generic z-wave.
I’ve also looked at the SmartThings api and it says that I dont have any devices yet.

Any advice greatly appreciated please as I’m feeling a little punch drunk and going around in circles.

Many thanks,

Just to verify, do you have the correct location (hub) selected in the new app before you try to add the lock?

Hi Andrew,

I can only see the one location/hub

Try this:

  1. Reboot your hub
  2. Bring your lock within 5ft of the hub
  3. Exclude your lock first
  4. Pair your lock

It should work if it’s a Z-Wave lock. You can optionally use this enhanced lock device handler to get access to your locks module 2 Z-wave Plus advanced feature.

@gph I had the same problem. I have the same Yale Keyless Connected lock and originally was using a v1 Z-Wave module successfully. I bought a new(er) v2 module because of the supposed improved security. I first unpaired the v1 module and then tried pairing the v2 module.

I was unable to do so and did all the resets etc. mentioned. I returned the module to the store and got a replacement - same issue exactly. I even spoke to both Smartthings and Yale support with no success. Yale did however send me another replacement and still it did not work. I even tried a second Smartthings v2 hub also with no success.

I was able to re-add the original v1 module which worked once more.

So that was three v2 modules, two v2 hubs and one Yale lock I ended up trying with no success.

As you might have gathered I gave up on the v2 module(s) completely. I have been waiting for the Yale Access Module which is based on the August technology Yale/Assa Abloy acquired when they bought the August smart lock company.

This new module was announced before Covid-19 but obviously release has been delayed. This should (hopefully) work and add a whole bunch of additional capabilities such as an open-door sensor, the ability to link to their new Linus Jr Euro profile lock and add remote control and HomeKit support.

@jelockwood Many thanks for your comprehensive message. Fortunately I have now got the v2 module to be recognised, however it only tells me the date/time the lock was activated, allows me to activate (lock/unlock) the lock from the app, and reports battery percentage.
So the Yale marketing material is misleading to say the least, and had I known prior to purchasing and putting a large hole through a solid oak door, would probably have gone for an alternative solution! It is annoying that Yale market it as allowing you to issue new lock codes remotely and for you to get notifications instantly, when clearly their system alone doesn’t allow this, instead you have to purchase an additional 3rd party app such as RBoy apps.
I think Yale should stop marketing a product that isn’t fit for purpose, or at the very least make it clear that you must purchase additional 3rd party software to get the functionality that they are claiming.

@RBoy Many thanks for your advice. I eventually managed to get the lock excluded and then paired again, for some reason it took more than one attempt.

I am coming to the conclusion that I need to purchase your Apps to be able to have the functionality I require with my lock system. My reluctance isn’t anything against yourself, it is merely I feel I have been let down by Yale who market a product that doesn’t work without purchasing software like your own and they don’t make this clear anywhere.
Before I do purchase please can you advise on the following:-
I have a Yale Keyless lock and Z-Wave module 2. I have it fitted in a property which is a shared house, so long-term tenants. The tenants each have a key tag to enter/exit, and cleaners etc have key codes for the lock.
If I purchase a personal licence will I be able to:
1/ exclude a key tag remotely
2/ issue/remove key codes remotely
3/ see which key tag/key code has been used to activate the lock in an audit trail

Finally if the answers are yes to the above, and I decided to have another lock at another property would I need to buy another licence for each property I have a lock at?

Many thanks for your assistance.

The features you are referring to do exist when the module is used with the Conexis L1 lock which is a newer lock than the Keyless Connected one. This may be partly related to the fact there is a dedicated official app for the Conexis L1 lock.

Unfortunately the Conexis L1 is a totally different type of lock so will not be a suitable alternative.

I don’t know yet if the Yale Access Module which will be compatible with both the Keyless Connected lock, the Conexis L1 lock and the forthcoming Linus Jr lock will add these missing features to the Keyless Connected lock.

What did you do to manage to get the module recognised by Smartthings?

@jelockwood I used RBoy’s advice up above of:

  1. Reboot your hub
  2. Bring your lock within 5ft of the hub
  3. Exclude your lock first
  4. Pair your lock

It took a few goes but I got it to do it eventually.

In terms of the Keyless not having the same functionality as the Conexis L1, whilst I’m sure you are correct in what you say, Yale do not state this on their website, so mislead the customer. Then, even more annoyingly when you call their customer technical support they claim it is nothing to do with them and that it is a Smartthings issue, despite the fact the product is marketed under the Yale brand name.

There’s no way to program RFID cards currently through SmartThings but with the Enhanced Z-Wave Lock device handler it can report RFID card usage.

Generally Lock User Management is used for keypad codes which can be programmed remotely but for RFID cards you can use the sister app as explained in this post for notifications and taking actions when the cards are used on the lock: [RELEASE] Lock User Management (LUM)

Some folks have been able to use both apps together with some elbow grease by duplicating the users in both apps and disable notifications for keypad users in one app but it’s better to use one app at a time with the keypad or the RFID tags. However it’s pretty flexible depending on how much you want to customize it.

@gph Realise this is 2 years later but having the same issue of not being able to press 1# to get into the pairing mode. How did you resolve this? Thanks

I’m having the same issue. Pressing 1# gives an error beep immediately, while pressing 3# seems like it tries to do something, before giving an error beep a few seconds later. 0 is not illuminated as an option to reset.

Anyone figure out a fix for this?