Yale YRD240 lock won't stay locked

I installed a brand new Yale YRD240 lock today with z-wave module. Lock seemed to discover and add ok, but when I lock the lock, 4 out of 5 times, it doesn’t stay locked in smart things. Within seconds it switches back to unlocked (though the physical state is still locked). Conversely sometimes when the lock is unlocked it’ll report in ST as locked. There doesn’t seem to be a physical problem with the lock. It turns smoothly and the bolt seats properly. I’ve tested it with the door open so as not to obstruct the bolt in anyway and have the same issue.

Needless to say, a mis-reporting smart lock is about 50% useless.

This problem is apparently so prevalent that smartthings has a whole page about it, but their offered solution, of removing/re-adding the lock did nothing for me.

I’ve also tried Rboy’s advanced universal DH. Same problem.

I bought this lock because its on the supported list and so many people claim they’ve had success with it. Is there some issue with secure vs insecure inclusion? The ST page I mention above alludes to that but I can’t find where to configure it anywhere.

Secure/insecure join is for ZigBee devices. I would guess that it is one of these two things.

  1. Your Z-Wave network is not strong enough to reliably get signals from the lock. Add a Z-Wave (non battery operated) device in between your lock and hub or move the hub closer.

  2. Your lock is sending a weak signal back. When I bought a Yale lock, the included batteries did not work well. Once I replaced them with name brand batteries my issues went away.

In both cases, you are probably not receiving the lock/unlock confirmation.

1 Like

I’ve got several of the 240s in two locations and never had problems with them within ST — but they are also fairly close to GE Z-Wave wall switches.

Lock is very close to the hub. I can literally touch both of them if I stretch my arms out.

I’ve noticed as well that the factory supplied batteries are not optimal, but I haven’t yet tried swapping them.

What ended up working for me is switching to this custom Device Handler:

As described here:

Not sure exactly why I’m having this problem and most others aren’t. I have another YRD240 coming this week and I’m curious to see if the default DH works with it or if I have to switch to this custom one as well.

Forgot to mention that I’m using Lock Manager (DTH and app):

Works well for me even in its beta stage. But I’ve also used Erik’s lock manager apps in all its incarnations with no problems at all.

1 Like

I just tried the ethayer Z-Wave Lock Reporting DH included with Lock Manager above and it also has the mis-reporting problem.

So far of the 4 DHs I’ve tried, only yracine : Custom Z-Wave Lock works for me.

Device Handlers that are mis-reporting lock state:

Zwave Lock (default)
rboy : Universal Z-Wave Lock With Alarms
ethayer : Z-Wave Lock Reporting

1 Like

Fresh batteries doesn’t help either.

1 Like

I just talked to both ST support and Yale support.

ST support says there’s a physical switch in the lock somewhere that could be causing the mis-reporting. Yale support says there is no such physical switch and they won’t comment about ST DH issues.

Sigh… it’s great that ST support is so nice, but real answers would be nicer!

The only other thing (other than staying with the working DTH) that I can think of to try is to re-seat the Z-Wave module if you haven’t tried already … and be careful — that tab on the module is pretty delicate.

I suppose if it work with Racine’s DTH, that should suffice — but that may limit you if other DTH and lock apps offer capabilities that Racine’s DTH doesn’t support.

Ok well, some rudimentary testing suggests that I am able to get both the ethayer Zwave Lock Reporting and rboy Universal Z-Wave Lock Device Handler DHs to report correctly with my Yale YRD240 by changing the lockandCheck function’s timeout from 4200 milliseconds to 2200 as suggested by yvesracine.

In both files:

def lockAndCheck(doorLockMode) {
		zwave.doorLockV1.doorLockOperationSet(doorLockMode: doorLockMode),
	], 4200)


def lockAndCheck(doorLockMode) {
		zwave.doorLockV1.doorLockOperationSet(doorLockMode: doorLockMode),
	], 2200)

Can anybody tell me how any of these DHs are supposed to behave in the case of manual intervention with the lock?

If I manually lock or unlock, is the DH supposed to poll and update its status?
Cuz it doesn’t.

OK, what I hope is the FINAL word on this issue.

I’ve finally got manual updates on this lock working too, but for now only using the rboy Universal Z-Wave Lock Device Handler.

I’ve got 2 of these locks now and it turns out that the first one’s rotational sensor isn’t reporting correctly, so its going back. The second one works perfectly.

So to sum up. Automatic lock state updates are fixed by the lockandCheck timeout change above, the manual state change update problem I was seeing seems to be a result of 1 of my locks not operating properly, which I discovered after installing a second one.


Thank you!! This appears to have resolved the issue with my YRD210 :stuck_out_tongue: