Yale Real Living Zigbee Issues with new Smartthings [Warning]

so, i have 2 Yale Real Living deadbolt locks (YRL-220) with Zigbee Controllers YRMZB1. I have been using the locks without issue for years now, and was using them with Rboy’s Lock User Management app. I switched to the new smartthings app, and after a few months, tried to update the smart app. after doing so, i started to have issues with codes not syncing with my locks. So I tried to reset them. This then broke my locks entirely… they would sync, but never work. always getting network communication errors.

I have spent the past 4 days trying different Device Handlers for the modules, and even tried new z-wave plus modules (do not do that… they were designed for the Assure line of locks YRD models and while they fit and can be seen by the ST hub, they do not work at all…).

I finally stumbled upon a post about network communication issues being somewhat common during the beta of the new smartthings app, and so i went back to the classic app (which they are making much harder to use now…) The locks immediately were detected and worked. I was also able to get the LUM smart app to sync codes without issues.

I dont know what’s going to happen when they kill the classic app, but I wanted to get this into the forum for others who may have the same issue, and hopefully save them a few days of anger, frustration and $…

I miss the classic app, this new one is ok, but buggy as hell and taking a lot longer to get used to…

Tagging @RBoy

There should be no difference between the new and classic app from a control/functionality point of view (the only difference would be the user interface for the devices in the new app which will be different from the Classic app and if you’re on the latest DTH’s then you should see all the functionality but in a different layout). The DTH and SmartApps themselves run in the cloud.

Since you’re saying that you’re able to control your locks from the Classic app and not through the new one, it’s not related to your lock, module, DTH or SmartApp. It sounds like an issue with the new app or your account/configuration w.r.t. to the new app.

I would suggest that you try to delete and reinstall the new app on your phone just so you’re using the latest version and sometimes it helps to clear the mobile phone cache and start clean.

If it still doesn’t work, I would recommend reporting it to support@smartthings.com so they can investigate why you’re able to use your locks from the Classic and not the new app. It’s possible they’ll throw it back because you’re using custom apps/dths. I’m going to also tag @blake.arnold @jody.albritton to see if they have any suggestions on how you can go about reporting this to support.

I got everything working now. Was able to delete and add one of the devices to the new app… i’ll try uninstalling and reinstalling next time, kinda want to let it be at this point and give the system some time to operate like it should :slight_smile: