Xiaomi & Aqara works but not showing temp on dash

Hello,

I’ve been using maybe 8 or so Xiaomi and Aqara temperature sensors for about a year or so. I have two IKEA outlets as repeaters.

A couple of months ago they all stopped showing temperature on the dashboard of Smartthings (the new app). They all still work and when I tap on them they do show temp and humidity. Automations also work based on their temperatures, so I know they work. They just don’t show temp on the front page anymore so I have to manually tap on each one to see the temperature.

All of them work in the old Smartthings app. I’ve tried removing and adding them without repeaters as well. They show up fine and is added to both apps as usual, but the temperature still isn’t showing in the new app.

I’ve previously had updates to the handler for the temperature sensors, but haven’t for a while now. Perhaps I’m supposed to add something else if that’s outdated? I’m not quite sure how to check that as I haven’t touched those things since I got everything set up.

All ideas are greatly appreciated! Thanks!

Another way to look at it is that the Aqara Temperature and Humidity Sensors are showing humidity on the tiles (if they don’t show ‘Getting status’). Humidity just seems to be favoured by the app over temperature, in the same way contact is favoured over a number of other capabilities. There might well be a suitable ‘vid’ that can be added to the handler to do the job. I’ve not tried as I have the atmospheric pressure measurement as well and I know there isn’t a ‘vid’ that supports that yet.

The tiles (if that’s what they’re called) only show “Getting status”.

Yes that is pretty common in the SmartThings app. It seems to mean that the app is trying to get the current status of the device but not all the attributes have been populated yet.

I find that if the device handlers make a point of initialising their attributes on installation, and that includes the units as well as the values (even though there are supposed to be default units), you just don’t see that. Chances are the handler is simply setting temperature, humidity and battery values and has never set the units for them.

Do you know if there’s anything I can do to fix it or were your talking generally?

Those tiles never change, it doesn’t matter how long it loads. Other tiles for lights, outlets and such work as intended still.

If English is not you default phone language it will give the checking status info, at least my does, when set to English all works fine.
I to have aqara temperature sensors and swap the dth for the xiaomi ones so the temperature shows in the main dashboard.

Sorry for the late reply. Thanks for helping out, changing my phone language from Swedish to English worked. This isn’t especially convenient though, but it’s better than not showing temperature at all.

I wonder if this is a DHT or SmartThings issue?