Working Speakers (44 Devices Confirmed , 29 waiting Confirmation) last addition: Klipsch Stadium, Help Us to increase the list

I picked up a D-Link Wi-Fi Audio Extender and Repeater (DCH-M225). When I play audio through it via DLNA it plays once, then starts to play it a second time and gets cut off.

For example, I’ve got an MP3 that says “Moisture detected near the water heater”. If I play that via this device, I hear “Moisture detected near the water heater. Moi”.

Any idea what could cause this? This is the third device I’ve tried from this list that hasn’t worked correctly. I’m perfectly open to the possibility that I’m the weak link :grin: , but all three have had different issues. Do any of the higher priced speakers “just work”? Am I doing it wrong?

Hi @btk , I think the problem is the device is in repeat mode, some similar issue was commented by @smorty71, you can try to use a control point app to disable the repeat mode, ( read the first post about control point RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)) I have a new version of mediarender device type who disabled repeat mode when a smartthings message is played and restored after finish, I will release this week, tell me if it fix your issue.

hi @btk, The Generic media renderer is “Generic” must work to every media renderer devices, but not all devices works equal, some load music fast or slow, some cuts off 1-3 second of audio, when this cut is for a 3 min music there are not problem but its a issue when a message of 5 seconds cuts 2 seconds, the device type have some settings to allow your media renderer works better with smartthings, try to read the first post of Generic media renderer to known how to adjust the settings.

Tell me what devices are you tested and did not work, @NinjaBread has reported the D-Link Wi-Fi Audio Extender and Repeater works fine, maybe he can help us to solve your problem

That certainly sounds like it could be the issue. Looking forward to testing the updated device type!

The R Pi 2 works with OSMC, the sound is pretty good on the “2” through the 3.5mm output. I also tried a B+ and the sound was awful, way too much interference.


1 Like

Bose soundtouch 20 Speaker System supports DLNA and should works with SmartTings

@ule The Bose Soundtouch 20 speaker does not work. Can confirm from my testing.

Hi @BenGroves Thanks for information, The speaker must to be DLNA compliant (information page confirms), could be external configuration the problem?

Could you help me to verify if there is a problem,

  1. Have you enable UPNP service in your router (The router could be blocking the dlna service)

  2. Have you any other DLNA speaker working in your network?

  3. could you find the bose soundtouch 20 with upnp browser app (ios), and send me a image from services? (if found it)


Hello, @ule.
The Bose Soundtouch 20 does not include the Generic Media Renderer requirement in it’s DNLA integration, preventing it from interfacing with your SmartApp. Also, it will not interface with DNLA without being online.

Either way, here’s the information you requested.

Yes, I have enabled UPNP on my router.

I have gotten my TVs working but they aren’t that useful because they only become a DNLA server when they are on.
I will get back to you tomorrow when I am able to physically turn them on without waking up everyone.

Hi @BenGroves, Thanks for your time to answer, I will exclude the soundtouch from dlna list.
I am intrigued about the working services in soundtouch, could you verify what kind of services have the sountouch with upnp app? I would appreciate it very much.

@officerduck did you ever confirm the A1 as working?

Hi @sgord, no, anybody has confirmed the Pioneer A1 is working with SmartThings, the A1 is DLNA compatible, but we need confirmation, if you have an A1 speaker maybe you can confirm this speaker. in first post there are information about confirmed speakers and waiting confirmation.


Sincere apologies.

I did have issues in that the A1 was not recognise and effectively had gave up. But I tried again some months later (was in the midst of moving house then).

And IT worked.

Don’t recall doing anything out of the ordinary but somehow the A1 needs to be in the mode when the LED is green for the smartthings to find.

Following the detect, I immediately set is such that it’ll announce when I’m back (through my smartsence presence sensor). Which means I never got to actually hear the announcement. Then one day, I’d left the A1 on, gone out and A1 was in sleep mode. Came home and a few hours later, my son mentioned that he heard the A1 making some announcement about me being in the building.

So, it works.

I’d recently removed the device and smartapp and just haven’t gotten down to setting it up again. One day, I’ll get down to setting it up and testing such that I actually hear the announcement for myself.

Update: Just tried setting up again and is now, not good - getting Error - bad state. Unable to complete page configuration.

1 Like

HI @officeduck, Thanks for replay, The error bad state. Unable to complete page configuration. is a problem from Smartthings platform, not the device, you can try again to add the speakers, the platform error fix some minutes after error, Are you agree if I add the A1 to working devices?

I have just tried getting a RPi 2 working with ‘Volumio’ DLNA renderer, and I can progress to the last step of selecting the renderer, but when I click the final “Done” button, I get the same “Error - bad state. Unable to complete page configuration”.

Anyone recently managed to get this working? Is a ST server-side issue as @ule is suggesting?

The OSMC website has been down for the past day, so I haven’t been able to check that.

I am using the RPi 2 with OSMC, easy set up and works well. See my post above RPI 2


I have now downgraded the SmartThings Android app (v1.6.9 from the Dropbox link in this post), and now I managed to get it working with the RPi 2 and Volumio audio music player.

Indeed, there seems to be something wrong with the current Android app…

I am waiting for my smarthub 2.0 but wonder if anyone has tested the Naim Mu-so soundbar.

I can confirm that these work. I have 2 of these speakers (Samsung M7 Shape). My favorite use is to have the Sonos driver have dogs barking when someone steps on the front porch.


1 Like

Is there any hope for airplay to ever work properly? I have read a few threads about using different ways to get some sort of functionality but would love for it to work perfectly.

1 Like