Why is Double Tap broken all of a sudden?

Why is the double tap smart app now throwing a groovy error around the “isPhysical” aspect of the app? This app has worked for 9 months no problem and now it is throwing this error. I have done a quick search and didn’t find much about it. Anyone know what is going on? I am lost as to what is wrong. Any thoughts?

“error groovy.lang.MissingMethodException: No signature of method: physicalgraph.app.EventWrapper.isPhysical() is applicable for argument types: () values: [] @ line 49”

the app sees a state change (this is just a single switch press, not a double"
“debug 1 STATES FOUND, LAST AT 2014-09-27T12:34:24.181Z”

I haven’t had a chance to look at logs yet, but in experiencing a sudden failure in all of my double tap apps now, too. Any advice appreciated!

My double tap no longer works as well.

I am seeing this as well. Any sense of when this last worked for you guys?

Have you installed iOS 8.0.2?

No I saw the (lack of) behavior prior to updating. That’s not it.

Similar problem, started happening about 2-3 days ago with no changes made on my end. Tried uninstalling and re-installing both the convenience and switch with no luck.

UPDATE (9/28/14 AM): Working again, looks like code was fixed.

Same problem here. I believe my apps last worked successfully on Friday (9/26/14).

It started working for me again this morning. They changed the piece of code that was causing the error from:

if (evt.isPhysical())


if (evt.physical)

Yes, that seems to have done the trick.

Yes we patched the SmartApp after a recent cloud deployment and so it works now.

Anyone know what actually happened here - ? Why was the change from .isPhysical() to .physical made necessary? Thanks - Doug.

As any derivatives one would have of this app were also broken, it would be nice to know when any language tokens are deprecated. Perhaps a repository could be created somewhere.

The problem was caused by a change that made the device.isPhysical() method start to fail. The work-around was to use device.physical

The change was not intentional, so the comment about deprecating language features doesn’t apply. We are intending to restore the original behavior, in which case both device.isPhysical() and device.physical will work.

My double tap is broken again. anyone else?

It’s broken again, due to last night’s unplanned system upgrade. I expect a fix to go out sometime tomorrow.

I’m trying to get this working for the first time and it doesn’t seem to be doing anything. Logs proving not very useful either. Does it require specific switches to be able to work? I’m using a Jasco 45609.

This has never worked for me with my Jasco GE switches.

Hi Eric,
I found the double tap app weird when I first tried it. Here’s what I found…

  1. It only works with on/off switch, NOT with a dimmer.
  2. You need to double tap slowly. Tap, watch 1st light go off, then tap again. (about 1 second between taps)

I’m using one to turn off all exterior lights (6 other switches or GE Link bulbs)

Weird. I tried that using a standard on/off switch that’s about 8ft from the hub and could never get it to work.

Does only the double tap device have to be on/off or do all switches in the action? (For example, can I double tap “Off” from an on/off switch and have it turn off a bunch of dimmers?)