When is smartThings hub going to integrate Lutron?

Sorry to ask, I had several of my lights automated using Lutron switches back in 2007, and they are still working great and my wife and kids just loved them. I am in the stage of updating the switches with z-wave enabled, so that I can control them with my iphone through smartThings hub; but I don’t want to remove the existing Lutron Switches which have been working great and every one in my family is used to. Does anybody know if smartThings have any plans to integrate with the Lutron devices any time in the future?

They probably don’t have any such plans. I built a RadioRA integration, that’s the older version of Lutron. If you have RadioRA2, that’s a different beast. RadioRA2 would actually be easier to integrate than RadioRA.

I am so sorry, I don’t know much about RadioRA or radio RA 2; but mine was IR based, the model is
Lutron MIR-600MT-WH Maestro IR 600-Watt Multi-Location Dimmer with IR Remote

The same model is selling on Amazon at

So I am not sure if it is RadioRA or RadioRA 2? You said, you had integrated radioRA, can you share how was this accomplished.



Check it out here:

1 Like

I have the hardware components and read about the jumpers on the Arduino board, but didn’t see any mention of what jumpers must be in what location on the RS-232 Shield. Can you please tell me what the jumper configuration is? Lastly, I want to confirm that there are no numbers on the Arduino board.?. I have Radio RA (not 2) and was excited to see this project. I am using a Lutron Chronos/Time Clock for my serial interface. It just isn’t cost effective to swap everything to RA2 and am looking very forward to getting my project to work just as yours. I hate to ask this question, but I’ve never entered/copied code into any of the boards involved. I do have technical background and would much appreciate a brief instruction on how it is done. Thanks in advance!

@bravenel is no longer active in the community, so I’m not sure you’ll get an answer if you can’t find one in the thread that he links to above. :disappointed_relieved:

Most of the Arduino folks hang out in the following thread, you might try asking your Arduino questions there and see if they can help.

1 Like

Thanks for you quick reply. I will try the other forum.

1 Like


I originally worked with Bruce (@bravenel) on helping him to use the Arduino with both an RS-232 shield and the SmartThings shield. If you look at his Arduino sketch, the clues are there as to how to wire the Arduino MEGA 2560’s extra hardware serial UART’s, but not overtly obvious to someone who hasn’t done a bunch of Arduino programming.

For my ThingShield “SmartThings” library, you’ll need to add jumper wires from pin 14 to pin 2, pin 15 to pin 3, in order for the following line of Bruce’s code to work.

SmartThings smartthing(HW_SERIAL3, messageCallout); // Hardware Serial constructor

My ThingShield “SmartThings” library, necessary for Bruce’s project to work properly, can be found at https://github.com/DanielOgorchock/ST_Anything/tree/master/Arduino/libraries/SmartThings

Bruce’s sketch also uses Serial2 for communicating with the RS-232 shield as seen in this line (and others) of his sketch. This will require you to add wire jumpers from pins 17 and 16 to the corresponding pins you configure the RS-232 shield to use.

  // set the data rate for the Lutron port

Bruce and I both came to the same conclusion that using the HW Serial UARTs on the Arduino Mega 2560 was the most reliable method of implementing serial communications. He originally attempted to use an Arduino UNO along with the SoftwareSerial library to implement both the ThingShield and RS-232 Shield communications. Unfortunately, the SoftwareSerial library can really only listen on one port at a time. Since Bruce’s project needs to be able to listen on both the Lutron serial port as well as the Thingshield serial port, he moved his project over to the MEGA 2560, and avoided the SoftwareSerial library altogether.

For your reference…
Details on the Arduino MEGA 2560 serial ports.
The Arduino Mega has three additional serial ports: Serial1 on pins 19 (RX) and 18 (TX), Serial2 on pins 17 (RX) and 16 (TX), Serial3 on pins 15 (RX) and 14 (TX).

Hope this helps you with your project!

Good luck and have fun!

1 Like

Thanks Dan! In the readme.txt file it stated to jump 2-14, 3-15, 4-16, & 5-17, which I did. I’m now in a somewhat confused state trying to get the files, in Bruce’s list, to the right spot and uploaded. I’ve downloaded the Arduino app on my Macbook and hooked the “Arduino 2560, Smart Thing Shield, and RS-232 Shield” stack to an open USB connector. I copied the Arduino sketch code and pasted it into the Arduino app and when I uploaded it to Arduino, received the following compiling error:

Arduino: 1.6.12 (Mac OS X), Board: “Arduino/Genuino Uno”

Build options changed, rebuilding all
/var/folders/_b/5q8bdnp17g3202649t3rj_mm0000gn/T/arduino_modified_sketch_218373/LutronRa.ino:6:25: fatal error: SmartThings.h: No such file or directory
#include <SmartThings.h>
compilation terminated.
exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"

With regard to the brief instructions that were given in the project - I don’t quite understand what is meant by ‘Device Types’ and how I get them to install in the ‘IDE’ (and that they need to be in “My Device Types”).
The Arduino Sketch I thought was pretty straight forward, but as I said I received an error when I copied the code and tried to upload it to the Arduino.
Then there is the Lutron Gateway SmartApp, that you install in the IDE. (Not sure how to do this either)
I must apologize for my lack of knowledge in programming this stuff and do appreciate your help as I really want to get my Lutron RadioRa devices to work via my tablet and phone. Thank you much!

-There are three Device Types that you need to install in the IDE - Lutron Shield, On/Off Button Tile, Virtual Dimmer.
These need to be in your “My Device Types”
-There is the Arduino sketch, that installs on Arduino Mega 2560.
-There is the Lutron Gateway SmartApp, that you install in the IDE.
-The Arduino RS232 shield connects to the RA-RS232 with null modem cable. There must be jumpers from pins 2,3,4,5 to pins 14,15,16,17 on the Mega.
option enabled in File -> Preferences.

Oh, forgot one thing. I got the wire jumpers installed, but was concerned about the J1-J2-J3 pin jumpers on the RS-232 shield … if it matters, how should they be configured?

SmartThings has changed their terminology from time to time. All of the following mean the same thing:

Device Type
Device Type Handler
Device Handler

And then it sounds like the following would be useful to you:

I am not much of a MAC person, but I will try to help…

First, in the Arduino IDE, you need to change the Board Type from Auduino UNO to Arduino MEGA 2560. Otherwise, the compiled code will not load properly on your MEGA.

Second, have you figured out how to install Arduino Libraries on your MAC? I believe on a MAC you need to copy the libraries into the ~/Documents/Arduino/libraries folder. As I stated earlier, you will need my “SmartThings” library found at https://github.com/DanielOgorchock/ST_Anything/tree/master/Arduino/libraries/SmartThings. That should solve the missing file issue you’re seeing.

Third, the jumpers on the RS-232 need to be configured to use the Arduino Pins 4 & 5. You’ll have to experiment to figure which one needs to be Transmit and Receiver for the RS-232 shield you bought.

Read the info the JD posted as it will help you understand how to use the SmartThings Web IDE to install Bruce’s 1) Arduino Device Type Handler, 2) SmartApp, 3) Virtual Device Type Handlers.