Wemo Connect Fails to Discover devices


#1

I had previously installed Wemo Connect and without issues it found all 13 of my devices. Recently however I renamed and moved several wemos and Wemo Connect did not reflect all these changes correctly. No problem… I’ll just uninstall and start from scratch. Big mistake. The 1st time it found 12 of my 13 devices but I could do nothing to get the 13th to appear. I once again decided to restart but this time it only found 6 devices. A final attempt and now I am down to 5 devices.

I have rebooted routers, hubs, restarted wemos.etc and at wits-end. I have no idea why the search fails to find all the wemos. The thing is that when I go in to the IDE under “MyLocation/Smart Apps/Wemo Connect” and click on the app link the new page has a section called “Application State” Within this section ALL MY WEMOS ARE THERE, But only the 5 are verified.

Anyone at all have any input??


Wemo integration
(Keith Croshaw) #2

When I renamed mine I had to delete the devices entirely. I’ve as of late given up on wemo integration for a while.


(Morgan) #3

I’ve given up on Wemo integration as well, it is so horrible I had to remove it from my environment.


(Chris Sanner) #4

I contacted support to complain about this a week or two ago and they pushed a firmware update to my system which fixed most of my problems.


#5

Interesting. What version(s) of the FW are you at now?

That said/asked… Last night they request more info from me and while I was getting it together all of a sudden all but 1 of my devices was discovered. This, after 1 1/2 days of getting nowhere. I responded to their request and told them there had been a significant improvement and within an hour (or less) the one remaining device was discovered. As far as I know, my FW was not updated.


(Keith Croshaw) #6

@Chris_Sanner what firmware version are you at? That you noticed improvement after.


(Chris Sanner) #7

currently on 000.013.00005


(Keith Croshaw) #8

Thanks, I’m at:
000.012.00074

Slightly afraid to ask for it because I’m not sure what else it might break…


(Allan Cardinal) #9

Been troubleshooting wemo and iphone integration for 2 weeks now. Support hasnt been able to fix either extremely frustrating. Works on Samsung android phones but not Iphones. Wemo well st says it’s compatible but that’s not true.


(Keith Croshaw) #10

I’m really confused how iOS would have anything to do with it. Your Wemo devices show the right status on an android device and not an ios?


(Allan Cardinal) #11

I can’t get ios to work on st. I briefly got one to show devices but nothing on dashboard worked and showed the wrong status. Uninstalled now it won’t even install as keeps saying mobile already exists even though logged out and app uninstalled. Tried 2 different iphones


(Keith Croshaw) #12

Oh not even in regards to Wemo? Just the ios app in general? That’s a mega problem. Try reinstalling the app obviously? I’m sure they’ve been through the list of things that could be ios’ fault.


(Keith Croshaw) #13

Just out of curiosity I re-added my two Wemo’s and they’re working now… Don’t know how much that helps people here.


#14

Well mine had been working fine till Monday . I even had two insights on. Then everything became erratic. Some worked other didn’t. Today I removed one that didn’t work and re added it. Now all my devices, including insights work again


#15

After many installs, uninstalls I can safely say that wemo integration with ST is not there by a long short. Initailly they work for a while then some (not all) will stop responding. Motion detectors may show constant motion yet logs indicate last motion days ago. Scheduled lights don’t come on when they should while other unscheduled light do. Pressing the on/off button appears to switch on/off a light but in reality nothing happens. I too am at FW 000.012.00074 and would certainly like to receive the update indicated above. That is, if that fixes this problem :smile: