Weird stuff going on with Linked Places and Location Names (Nov 2021)

This morning I deleted a device I was using with the ‘notification’ capability that was used in a few routines. Naturally the app deleted the routines because it thinks that is reasonable.

I started recreating the routines and then got sidetracked.

Revisiting the routines this afternoon, I discovered that I seemed to have deleted one or two of the routines while I tried other things but I have no recollection of doing so. But bizarrely it now thinks that I am the only one with a Galaxy phone and is refusing to let me use Linked Places in my routines for the other members as I was doing this morning.

I then also noticed that my Location name was wrong. I changed it recently and it had reverted to the previous name. Not sure when that happened.

Update: Edited the text above to note that I don’t actually recall deleting the routines I created this morning. Indeed I am pretty sure I didn’t.

OK I think I’ve seen what has happened. There has been a tweak to Linked Places that has added a ‘friendly’ label to the components of the mobile presence device (that is how Linked Places are implemented). So for example, main now has a label that is the Location name. That is very welcome as they only had a UUID previously.

This has worked fine for the mobile presence device of the location owner, but for the guest members the Linked Places, the components, have been erased from the devices. Hence why Routines I was sure I added this morning disappeared during the day.

@nayelyz and @erickv, is this within your remit?

Tagging @Brad_ST

I’m not too familiar with Linked Places and automating them and am a bit confused. “but for the guest members the Linked Places, the components, have been erased from the devices.” So everything works fine for the owner but shared users aren’t able to automate Linked Places? Or the owner can’t create automations for shared users and Linked Places?

1 Like

OK I should probably qualify my comments. I am the location owner and I have been in and out of my mobile app on and off all day. The shared users are either disinterested or blissfully unaware that they even have SmartThings apps installed, though I did open one briefly earlier.

The Linked Places on Samsung Galaxy phones are implemented by adding components to the mobile presence device for each phone. However over the course of the day, those components have vanished from the mobile presence devices of the shared users. I haven’t done anything, their phones were miles away at the time.

So regardless of who is creating automations/routines (and indeed Rules and SmartApps), Linked Places now only work for me. The mobile apps think the others don’t have Galaxy phones any more because the devices have somehow been changed.

OK, having been able to get hold of the other phones, it seems the very act of opening up the phones and going to Manage Location is enough to get the presence sensors to correct themselves.

Curiously one phone reports the Geolocation as if it has never been set up, yet knows exactly where it is when clicking through to the map.