Webcore Pistons not firing (November 5, 2017)

Anyone know how to hard reload iPad Safari browser? I keep getting the

“A newer UI version (v0.2.0fd.20171105) is available, please hard reload this web page to get the newest version.”

Use a computer and load your web browser and hold CTRL+F5 together until it starts to reload the page then release.

I’m using Chrome.

0fd is the most recent update.

Settings —> Safari —> scroll down to clear history and website data.

I’ve pushed a new update on the piston smart app (same version though) that should take care of the time difference during the early hours of today - adding a day to that (i.e. every day at 3am) was causing tomorrow’s schedule to happen an hour early.


Your probably still sleeping out on the west coast. Just wanted to give you some information to report.

The Pistons are firing off this morning and at correct times. I am still seeing
datetime$nextScheduledTimeInvalid Date under the “Variables” section of the web browser. Under the “Quick facts” it is reporting the proper “Next scheduled” time event.

One thing to further report, I have a Piston to run at a daily time (6:50AM) but only Monday - Friday. This morning at 6:50AM (on a Monday) the Piston did not fire. I have updated your latest Piston from IDE and did a hard reload again and did a test Piston with the same results.

Can you please share that test piston? Thank you

My pistons still don’t seem to be firing at all.

Are all 4 of the webCoRE instances at 0fd?
If not, update asap if you want things to work.

They are now thanks

Yep, I just updated the IDE and waiting to see if the problem is fixed.

I deleted the last one but just made another one this evening. Scheduled it for 5:53 and I ran a trace and this is what happened.

Works for me… not sure what happened there?

Not really sure what I did. I did a forced re-load again, double checked IDE that there wasn’t an update. Did a force re-load again. Deleted the test and made a new test and this time it worked.

Carry on. Nothing further.

I’m on an older version and didn’t notice any issues. I’m on 0.2.0e2. Does that make sense? I generally only update if an issue I need is fixed or some new feature I’d want to use is added. I used to be update and live on the edge with most things but now I’m if it ain’t broke don’t fix it.

Thanks. Updated for future protection.

I’m running the latest instance of webcore (0.2.0fe), but am facing a strange situation where my piston that comes on Mon-Fri at 6am, (UK time) doesn’t seem to automatically re-schedule any more? Instead, it states ‘next scheduled - never’ and does not show t countdown timer on the home page.

The only way to fix it is to seemingly open the piston and edit/save to get it back. Is this a nuance of the time issues discussed in this thread? It worked just fine before…

Any advice would be appreciated, piston in question below:

Thanks for clearing that up Robin.

I’ve noticed that it does fire every time the temperature changes, which can be annoying as sometimes I turn the heater on manually and the piston switches it off.

Is this just a nuance of the technology, or is there a way I can get it to only evaluate and run during the stated time window?

Many thanks again.

Thanks Robin, looks like I’m about to venture into my next webcore learning curve!

Seems like there are some issues or I have issues with pistons that needs restart before they work again. Am I the only one?