WD500Z-1 dimmers cannot get the lights to turn off 100%?

Hey guys, I am brand new here!

I bought several WD500Z-1 dimmers and most are working perfect!

Only a few of them, I cannot get the lights to turn off 100%?
(The UI shows Off / 0% but lights are still at x% )

Please let me know if you have any ideas/suggestions
Thanks in advanced

these are supposed to work well with low loads such as 9watt LED, even though if a user re-lights to a low dim level then perhaps it will not actually light-up at that level - but that is not the problem you describe.

I’d try it with an incandescent bulb at least 40watt to see if the issue persists. That would confirm the problem is load-dependent.

Your issue of commanding off, but remaining on at a low%, to me it suggests a bad neutral connection to the switch/dimmer.

1 Like

This is not uncommon. I have Cree connected bulbs. I have one bulb in my bedroom & the room gets totally black. After installing the bulb and eyes adjust to the darkness, I can see the bulb. Nothing else just the bulb. It’s very faint but it’s there. It shows to be 0%. Somebody said something similar regarding Cree bulbs, possibly about a year ago now.

I don’t remember if these require a neutral or not.
I have one of the original GE Z-Wave dimmers in our living room that did not require a neutral, and the lights come on a tiny amount when we shut the switch off entirely.
All of my other neutral enabled dimmers work just fine.

The way I remedy the issue is to have an incandescent bulb in one of the fixtures. Eliminates the issue entirely.

I couldn’t get this switch to work for me. I tried to replace an Insteon dimmer switch, which worked perfectly fine with LED bulbs, but the bulbs would not completely shut off. So I went back to the Insteon dimmer switch and returned the WD500Z. If it works on other light fixtures, take those bulbs and place them on the ones that you are having trouble with. That way you can see it the problem lies with the bulb or the switch.

1 Like

I removed all LED bulbs and changed it back to incandescent bulb - issue remained first BUT after a time it worked :grinning:

So now I need to test, which are the best LED bulbs to get this working…

1 Like

Check your neutral at your switch then. This sounds like either a neutral issue or a failed switch.