Visonic MCT-340 SMA sensors randomly offline

I’m using four Visonic MCT-340 SMA door sensors that I initially got from Comcast. I got them to work with the Device Handler written by Tomas Axerot (thank you for that). Now I have noticed that they randomly go “offline” after a few days. Sometimes all of them, sometimes just one. Often they come back online after a few hours. Sometimes they will not have come back online after a few days. I can fix it by starting the scan for new devices, removing the battery cover then replacing it. This seems to cause the device to re-pair. When I read that the third party device handler was no longer necessary, I removed that and the sensors work as expected but still occasionally go offline. I have rebooted the hub and followed the reset process (holding the tamper switch) for each of them. Any thoughts on the cause and/or a way of being notified when a sensor goes offline?


I have an Xiaomi sensor that was dropped periodically and found an APP called Device Monitor that alerted me when a device wasn’t online. Has worked well for me so far.

Here’s some things to check…

WiFi Interference - to narrow out Interference check your ZigBee Channel in the IDE. Log in and click on ‘My Hubs’ scroll down to the Zigbee Section and see what channel its using. Then check your zigbee channel against your current WiFi channel on your Router. Here’s a site you can use to cross-reference

While you cannot change your Zigbee channel you can change out your WiFi channel on your router, also if your router support Auto-Channel disable it and select the channel manually and move it as far as possible from your Zigbee Channel. For me I’m on Zigbee Channel 19, so I selected Channel 1 on my WiFi

Also, if you still happen to have a landline with cordless phones make sure the hub is not near that base station as well to narrow out any possible interference from that, unlikely but might as well be 100% positive.

Distance - if its too far from the hub you may need to add a plug or switch or 2 to increase the mesh. If you already have plugin/hardwired devices you may need to rebuild the mesh.

Zigbee Utilities - In the IDE Check to see if Allow Unsecure Rejoin (Most Compatible) is set, if not set it to that.

Jimmy, thanks for the tips. I’ve changed my WiFi channel and confirmed the Unsecure Rejoin setting. I’ve also added a monitoring app. I’ll see how it goes.


One other comment. Initially when I discovered that my ZigBee channel was 14, I changed my WiFi channel to 1. However after I looked more closely at the documentation included by Jimmy James, the chart shows that there is an overlap between those channels. Interestingly there is no overlap between ZigBee 14 and WiFi 11 which is how I am now set. If others are interested in making such configuration changes I would recommend reading this short article mentioned in the Jimmy James post.