Vision In Wall Z-Wave Micro Switch, 2 relay does not sync

Hi, you are using the multichannel device type of SmartThings or a custom device type? My multichannel switches are not working since yesterday. They turn on buth they dont refresh the status. I opened a TT with support but no news yet.

I am using a custom DTH and don’t see any problem.

exactly same problem as LucasAr im using My multichannel switches, i had it for one week now

The custom devices are not experiencing problems. The issue is caused by the provided MultiChannel DeviceType and the SmartApp which manages the VirtualEndPoints. I moved all my devices (+15) to custom device types and it solved the issue. The answer from support was “those devices are not officialy supported” so i gently send them to a far far away place and moved everithing. If you need my code let me know.

thank for your help, now I’m using Custom Device Type for Monoprice 11990 Dual Relay Module, but I showing two switches on one switch, on smartthings app how can I fix that

You should have one tile with the device and a Virtual Device per endpoint. Its managed through an App, do you have that App installed?

see the pic, I don’t have that what they call it and from where can get it to separate those switches

Try using the default smartapp, go to: Add SmartApp, +More, Multi-Channel Control and select your device and assign a name to it.

thank you, it working i used you first advice (creating Virtual Device and following the steps

thanks again

I checked on the support site and the Multi-Channel device type was discontinued in July. My Switch stopper working, too. I installed the custom Monoprice device type and smartapp and it works fine, now. Not real happy with SmartThings right now as I recommended this device to a number of people. Does anyone know of a “standard” device type that will work with a Multi-channel device on Smartthings?

That the only working link so far ( ) just try it again let me know if worked

Yes, the Device handler and Relay from justintime guthub work great (actually better than the stock one). But it is hard for me to tell my non-technical friends to go into github and grab the code. ;-0

So just creat YouTube video to show the tutorial and share it with your friends

Thanks for this. My multi-channel devices suddenly stopped working correctly. Removing and adding the devices just made things worse. This module solved the problems I was having with the device.

Thanks again…

I used the justintime DTH and App and Smartthings is still not updating the status when I used the physical switch. Anyone else having this issue? Mine is part number ZL7432US
if that helps

Mine never updated its status. So I re-read the instructions just now, and discovered I had never created the virtual switches. I had specified the real switches as the virtual switches, linking them to themselves, probably creating an infinite loop somewhere. I’m surprised the universe still exists and didn’t’ collapse into a singularity. Anyway, it seems to work better now!

I’m having this issue also. I have @justintime’s DH and Smart app installed with the 2 virtual switches and they don’t sync properly if the physical switch is toggled the status doesn’t update in Smartthings. If it’s out of sync and I toggle the virtual switches the status updates but the physical device doesn’t change state so the virtual switches and physical devices re-sync but as soon as the physical switch is toggled smartthings fails to update the status. Any ideas of what could be wrong? Thanks in advance.

1 Like

Try removing devices and create new once

Updating for 2020. I have the ZL 7432 Vision in-wall z-wave dual relay and had similar problems getting it set up with the SmartThings V3 hub and the Samsung SmartThings (new) mobile app. All of the linked code didn’t work for me with the new app. Steps I followed to get it working properly:

  • Add it in the app as a “Generic Z-Wave device” (flip the switch on/off four times to put into pairing mode)
  • Go to
  • Go to My Devices
  • Click the device you created in step one above
  • Go to Edit at the bottom
  • Under Type pick Z-Wave Dual Switch and hit save
  • Restart the SmartThings mobile app. You should see a new second switch at the bottom which you can move into the same room as the first switch. Try both and they work! :smiley:

new app was failing to save scenes with these devices in them. this worked to get them running again. thanks!