Virtual Switches stopped working

My virtual Switches have stopped working. Any ideas?

(Just as I typed that I got a push notification that my hub has disconnected… uh…)

Bump… anyone have any idea what’s up with virtual switches?? They are the primary way we use Smartthings and they are not working. When we try to use them we get network errors and our hub goes offline for about half an hour. Five days of this now… I’ve reported it to Smartthings every day since the 8th. No response yet to any of my reports/requests for help.


My virtual switches are all working fine, so unless someone else comments that they also have this problem it might be an issue specific to your hub / account.

Perhaps unrelated about every hour our home hub disconnects every couple of hours and then reconnects. I really hope this doesn’t happen all night (midnight here in California).

And lots of “network or server” errors… ever since Sept 8th.

I have verified that any changes I make in the app are reflected in the IDE and our local network tests have yielded no problems. I have rebooted the hub (pulled the plug) five days in a row with no success.

I am now able to repeat the problem: All I have to do is turn a couple virtual switches on (which fails with the network error) and a minute or so later our hub will go offline. I can cause this to happen every time. So something is up I’m just not sure what it is.


Bump… this is still happening. Six days of this nonsense. Is anyone else having the same problem?

All of my 14 virtual switches with 5 of them being Alexa (non-momentary) virtual switches are all functioning normally with everything using them from SmartThings Automations and SmartApps to Alexa Routines.

I’ll bet the root of your problem is due to the Hub errors you are experiencing so SmartThings support would need to advise you on what’s going on with it. Good luck.

Today, all of my virtual switches stopped working. They were stuck, and while their state could be read, nothing could change them. I have automations which sync the virtual switches to my Smart Home Monitor State and could not ‘disarm’ my home.

I tried rebooting the hub, and then tried power cycling the hub. Nothing worked.

I added a new virtual switch in the IDE and then all my virtual switches started working. I don’t bother raising a support ticket as they don’t offer support for Virtual Switches. Hope this helps someone.