User created app in ST app?


(esung) #1

So I tried to publish an app from IDE but I don’t see it showing up in ST app. Do user-created app not appear in ST app? (iOS app)
Thanks.


(Ronny Carr) #2

It should be in the specified category when you go to install a new smartapp.


(esung) #3

Thanks Ronny. That’s what I assumed, but it doesn’t show up. I must be doing something wrong.


(esung) #4

So I start a new app, overwrite it with an existing app so that I know it’s a functional code, set the location to my ST hub and publish it for myself. (I don’t see any option but ‘for me’ only).Anything I forgot to do?


(Ronny Carr) #5

If you are asking about when you install an app through the IDE, it will not show in the mobile app. You can only edit the app from the IDE.


(Brian Steere) #6

I’ve only had luck publishing apps in the My Apps category.


(esung) #7

@ronnycarr Thanks. I’m not trying to install the app from IDE, but to publish it so that it would show up in ST app and install it from there. I tried different categories but no avail, and I don’t even see ‘my apps’ category at all. Any switch I forgot to turn on?

Thanks


(Ronny Carr) #8

I guess they have to be in the ‘my apps’ category to show in the mobile app. So when you go to create a new app in the IDE, on the settings page where you give it a name, the category picker should have ‘my apps’ as one of the options. If that category isn’t available in the IDE, I wouldn’t know why.

As far as publishing goes, it sounds like you have that part right. Just click ‘publish’ and choose (like you said, only option) ‘for me’.


(esung) #9

Thanks. I chose ‘my apps’ category in IDE but I don’t see that category in ST appstore at all. Only those usual ones like convenience, family… etc.


(Greg) #10

Defcon - I had this same issue. In some other thread I found instruction that you have to sign out of your mobile app on your phone. When you sign back in the myapps category is magically there. Worked for me.


(esung) #11

Thanks a lot @greg! That worked like charm.


(Elijah Low) #12

I am new to ST and this is my first time trying to publish a smart app. It doesn’t show up in the ST app for me even after setting it to “My Apps” category and logging out and logging back in - in the ST app. What else should I be checking?


User Created App not showing up in ST app