Updates to the SmartThings Platform

Ha just read the thread I posted and you will find your answer. I’ll leave it at that :slight_smile:

1 Like

Just finished my painful migration… Are Automation mode preconditions not working properly for anyone else. For example the automation below is still firing when a door opens when the current mode is Home.

Links to Official Threads on Migration2020

3 Likes

Great @JDRoberts!! You’re very helpful, and always gracious :slight_smile:

1 Like

The TL:DR about that thread: several people are trying. It is very active and SmartThings developers are actively participating to help. But, no one has succeeded yet.

4 Likes

I use Konnected and made the transition. I didn’t experience any issues. I had already migrated to Konnected Cloud in the classic app though, so can’t speak to the old smartapp.

OK, thanks for that! I refreshed the switches and now the Smart Lighting options are there as they were a month or so ago (can choose switch 1, switch 2, switch 3, etc… as a trigger). Not intuitive, but something that I can figure out. That said, I think I’m going to try out your other option you mentioned and I’ll keep track of things in the other thread since it seems this is now less relevant to this particular thread. Thanks for working on this! The WD200+ Dimmer switches are awesome.

2 Likes

Custom capabilities that just report state are working (there are probably some caveats to that, but I’ve had a sensor reporting salt level in my pool for a few weeks). The CLI is also working to create custom vids if you’re just using stock capabilities. The hurdle that no one seems to be getting past right now is getting a custom capability with a button or any other interface that kicks off an action to work.

2 Likes

@DIYMakerDad - Okay, thanks. I was thinking you had to use the New ST App in order to migrate to Konnected Cloud at all. When you migrated to Konnected Cloud, did ST Classic recognize all your Konnected sensors/devices, and keep them as part of any SHM or Routines you had already set up? Or, did you have to go through and remove the “old” Konnected devices from those Routines, and re-add the “new” Konnected devices?

Wait my nutty tree still works in new app?

Try setting up a new SmartLighting automation using the double-click “button”. Don’t modify an existing one, it will (probably) break and become unrecoverable. When I select the button property of the switch, I get a “network not available” error and that automation can’t be accessed anymore. The only way to remove it is through the IDE.

1 Like

They don’t appear wot work properly using an OR condition. AND seems to work.

Annoying. Hopefully they are aware. I opened a ticket anyway.

1 Like

WebCoRE could execute a Piston based on a Classic App "Routine" executing. What’s the equivalent in the New App? I loved the ability to use Routines as “virtual button” because Routines did not take a device slot but Alexa could execute them. As I already have a high count of devices, I can not afford to make Virtual Switches or Buttons for every webCoRE Piston that I need to fire.

Thanks.

3 Likes

Unfortunately, that’s what we need to do right now… :frowning:

4 Likes

Yes, please PM me with other issues you’re having. We’re keeping a list of anything community users are seeing and triaging as appropriate.

2 Likes

Hi Blake -

I’ll get it to you before the week is out.

R

2 Likes

Just had a new SmartApp create about 10 new devices. I started looking for them, and I had to painfully add EACH to an existing room using the dreaded devices view! That was about 5 keystrokes per device (50 clicks reminds me of MS Windows 3.1) , which used to be done in the classic app which showed new devices that were not assigned to a room and allow one to select them to add all at once!

Ami I missing a trick to do this the way it was done in the good ole days?

1 Like

Long press on the device and you can choose a new room

4 Likes

Thank goodness for that hidden feature, so much for making this also presented in the 3 dot top menu choice… I tried the long press on an existing device (it was assigned to a room), and this long press does not function as you describe on iOS device. Is this hidden feature just for devices not assigned to a room? :nerd_face:

But I (and I’m sure others) would still like to have the ole capability of being in a room and finding devices not assigned to a room and add all at once! So much for productivity. :hot_face: